This is an automated email from the git hooks/post-receive script.

js pushed a commit to branch master
in repository libkavorka-perl.

commit e2054b588839311aee202486930b9edd97104c59
Author: Jonas Smedegaard <d...@jones.dk>
Date:   Tue Feb 24 15:05:28 2015 +0100

    Fix tighten build-dependency on libscalar-list-utils: Sub::Util only 
included in newer versions than than provided by perl.
---
 debian/rules | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/debian/rules b/debian/rules
index 37fb522..894915b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -27,11 +27,13 @@ DEB_UPSTREAM_PACKAGE = Kavorka
 DEB_UPSTREAM_URL = http://www.cpan.org/authors/id/T/TO/TOBYINK
 
 # Needed by upstream build and (always) at runtime
+#  * Recent Scalar::List::Utils needed for Sub::Util
 perl-deps = data-alias exporter-tiny module-runtime padwalker
-perl-deps += parse-keyword return-type scalar-list-utils type-tiny
+perl-deps += parse-keyword return-type type-tiny
 perl-deps += match-simple namespace-sweep
 deps = $(patsubst %,$(comma) lib%-perl,$(perl-deps))
 deps +=, libmoo-perl (>= 1.003001)
+deps +=, libscalar-list-utils-perl (>= 1:1.40)
 deps +=, perl (>= 5.14)
 
 # Needed (often) at runtime

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-perl/packages/libkavorka-perl.git

_______________________________________________
Pkg-perl-cvs-commits mailing list
Pkg-perl-cvs-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-perl-cvs-commits

Reply via email to