This is an automated email from the git hooks/post-receive script.

gregoa pushed a commit to branch master
in repository libcgi-application-plugin-authentication-perl.

commit 7a4e4ca456a62783a75471c7cb5375a4157b2e36
Author: Micah Gersten <mic...@ubuntu.com>
Date:   Thu May 21 21:48:48 2015 +0200

    Add new patch from upstream bug tracker that fixes more warnings
    
    which are causing this package to FTBFS with newer Perl 5.20 and CGI.pm 4.05
    - add debian/patches/fix-more-warnings.patch
    - update debian/patches/series
    
    Closes: #786447
---
 debian/patches/fix-more-warnings.patch | 72 ++++++++++++++++++++++++++++++++++
 debian/patches/series                  |  1 +
 2 files changed, 73 insertions(+)

diff --git a/debian/patches/fix-more-warnings.patch 
b/debian/patches/fix-more-warnings.patch
new file mode 100644
index 0000000..d959c90
--- /dev/null
+++ b/debian/patches/fix-more-warnings.patch
@@ -0,0 +1,72 @@
+Description: [PATCH] Silent various warnings
+ Some of them fail tests which sniffs for warnings. Some warning were
+ introduced by CGI 4.05 or recent (5.20) perl.
+
+ This is the same patch from the upstream tracker except the block that 
matched 
+ the other CGI.pm patch was removed.
+
+Origin: other, 
https://rt.cpan.org/Ticket/Attachment/1495484/796570/CGI-Application-Plugin-Authentication-0.20-Silent-various-warnings.patch
+Bug: https://rt.cpan.org/Public/Bug/Display.html?id=99460
+Bug-Debian: https://bugs.debian.org/786447
+Author: Petr Písař <ppi...@redhat.com>
+---
+ lib/CGI/Application/Plugin/Authentication.pm                     | 1 +
+ lib/CGI/Application/Plugin/Authentication/Driver/Filter/crypt.pm | 2 +-
+ lib/CGI/Application/Plugin/Authentication/Driver/Filter/md5.pm   | 2 +-
+ lib/CGI/Application/Plugin/Authentication/Driver/Filter/sha1.pm  | 2 +-
+ 4 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/lib/CGI/Application/Plugin/Authentication.pm 
b/lib/CGI/Application/Plugin/Authentication.pm
+index 83230d2..2908925 100644
+--- a/lib/CGI/Application/Plugin/Authentication.pm
++++ b/lib/CGI/Application/Plugin/Authentication.pm
+@@ -767,6 +767,7 @@ sub is_protected_runmode {
+     my $self = shift;
+     my $runmode = shift;
+ 
++    require overload;
+     foreach my $runmode_test ($self->protected_runmodes) {
+         if (overload::StrVal($runmode_test) =~ /^Regexp=/) {
+             # We were passed a regular expression
+diff --git a/lib/CGI/Application/Plugin/Authentication/Driver/Filter/crypt.pm 
b/lib/CGI/Application/Plugin/Authentication/Driver/Filter/crypt.pm
+index 48dd28d..07377d4 100644
+--- a/lib/CGI/Application/Plugin/Authentication/Driver/Filter/crypt.pm
++++ b/lib/CGI/Application/Plugin/Authentication/Driver/Filter/crypt.pm
+@@ -15,7 +15,7 @@ sub check {
+ 
+ sub filter {
+     my $class = shift;
+-    my $param = lc shift; # not used
++    shift; # not used
+     my $plain = shift;
+     my $salt  = shift;
+     if (!$salt) {
+diff --git a/lib/CGI/Application/Plugin/Authentication/Driver/Filter/md5.pm 
b/lib/CGI/Application/Plugin/Authentication/Driver/Filter/md5.pm
+index 4b51ecf..56a0bea 100644
+--- a/lib/CGI/Application/Plugin/Authentication/Driver/Filter/md5.pm
++++ b/lib/CGI/Application/Plugin/Authentication/Driver/Filter/md5.pm
+@@ -25,7 +25,7 @@ sub check {
+ 
+ sub filter {
+     my $class = shift;
+-    my $param = lc shift || 'hex';
++    my $param = lc( shift || 'hex' );
+     my $plain = shift;
+ 
+     Digest::MD5->require || die "Digest::MD5 is required to check MD5 
passwords";
+diff --git a/lib/CGI/Application/Plugin/Authentication/Driver/Filter/sha1.pm 
b/lib/CGI/Application/Plugin/Authentication/Driver/Filter/sha1.pm
+index 610e9fa..b9f2f24 100644
+--- a/lib/CGI/Application/Plugin/Authentication/Driver/Filter/sha1.pm
++++ b/lib/CGI/Application/Plugin/Authentication/Driver/Filter/sha1.pm
+@@ -25,7 +25,7 @@ sub check {
+ 
+ sub filter {
+     my $class = shift;
+-    my $param = lc shift || 'hex';
++    my $param = lc( shift || 'hex' );
+     my $plain = shift;
+ 
+     Digest::SHA->require || die "Digest::SHA is required to check SHA1 
passwords";
+-- 
+2.1.0
+
diff --git a/debian/patches/series b/debian/patches/series
index e91b6bd..66801a7 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +1,2 @@
 cgi.pm-4.05.patch
+fix-more-warnings.patch

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-perl/packages/libcgi-application-plugin-authentication-perl.git

_______________________________________________
Pkg-perl-cvs-commits mailing list
Pkg-perl-cvs-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-perl-cvs-commits

Reply via email to