This is an automated email from the git hooks/post-receive script.

gregoa pushed a change to annotated tag upstream/1.7039
in repository cpanminus.

        at  6feb7af   (tag)
   tagging  3336022b2887f0d2631c6a7a9eb9fbd82abc8bc7 (commit)
  replaces  upstream/1.7014
 tagged by  gregor herrmann
        on  Sat Jul 25 16:32:16 2015 +0200

- Log -----------------------------------------------------------------
Upstream version 1.7039

Gareth Kirwan (1):
      Respect provides in META before using Parse::PMFile

Kahlil (Kal) Hodgson (3):
      core modules may be installed under 'vendor' paths
      Dont assume vendor paths are defined
      use 2 arg version of grep for older Perls

Sebastian Riedel (4):
      use HTTPS instead of HTTP
      added -M option as a shortcut for --mirror and --mirror-only
      renamed -M option to --from
      added -M as an alias for --from

Shoichi Kaji (2):
      keep mirror index file as absolute path
      when resolving name, try git uri first

Tatsuhiko Miyagawa (110):
      reorder the wording. #369
      add a script to automatically merge devel to master
      add git push
      up PMFile to 0.29
      bump CPAN::Meta::Requirement to 2.129
      common-sense 3.72 is pulled from CPAN
      1.7015
      Merge pull request #416 from kraih/devel
      Merge pull request #417 from kraih/devel
      1.7016
      document --from/-M in pod/man
      bump fatlib
      1.7017
      bump version
      1.7018
      change the header comment
      bump Parse::PMFile to 0.30. Fix #419
      1.7019
      bump Parse::PMFile to 0.31
      1.7020
      bump 0.32
      bump HTTP::Tiny
      1.7021
      add UNSAFE and ALLOW_DEV_VERSION
      1.7022
      delete VERSION. Fix #420
      bump fatlib. Fix #424
      1.7023
      fix copyright
      Merge pull request #426 from tartansandal/add-vendor
      bump
      1.7024
      bump fatlib
      bump fatlib
      bump fatlib
      1.7025
      Merge pull request #435 from gbjk/feature/respect_provides
      1.7026
      Respect provides if it's there, and stop extracting packages. #435
      test for the provides
      1.7027
      Merge pull request #438 from shoichikaji/abs-mirror-index
      use HTTPS
      Add troubleshoot for curl SSL errors/wanings re #441
      doc overhaul for first time users
      1.7028
      unit test to reproduce cpanfile requirement issue. #363
      refactor to use merged_requirements
      keep cpanfile requirements object and merge it when chasing for sub 
dependencies.
      more test
      add comment
      update test to be less brittle
      Merge pull request #446 from miyagawa/cpanfile-pinning
      actually these requires are not necessary
      Revert "retire --metacpan officially. #403"
      document --metacpan
      bump fatpack
      1.7029
      1.7030
      disable report perl versions if running under CI
      failing test for #452
      when ensuring required versions are satisfied, use the original META 
requirement. Fix #452
      speed up tests by eliminating deps with slow tests
      remove this test
      enable -j9
      speed up slow test
      skip Module::Build tests
      run this test with -L so it won't intefere with others
      run this test in an isolation
      make this test more reliable
      make the test target a smaller repo
      notest
      1.7031
      make notest the default.
      added a reference to git.io/cpanm #453
      Only allow backpan with the specific version search.
      typo
      use cpanmetadb history API.
      1.7032
      remove unused
      Remove MakeMaker and Module::Build from runtime deps, rather upgrade them 
as you go in the actual installation.
      comment the reasoning
      1.7033
      ignore Menlo- dist
      Give an easier-to-understand error message on requirement merge conflicts.
      make the test case work with 5.8
      relax the error message matcher since the order could be random.
      fix the syntax error in .t
      1.7034
      bump Run::BeforeBuild
      fix the test to actually set ENV
      Workaround for M::I 1.04 creating a bogus MakeMaker prereq in build 
requires. #463
      better test, to make sure that the dist is actually installed successfully
      1.7035
      remove from runtime too because Module::Install 0.79 does that.
      fix tests to work with the MakeMaker runtime workaround
      1.7036
      Update fatpack
      Successfully installed CPAN-Meta-Check-0.012 (upgraded from 0.011) #465
      1.7037
      bump minimum perl requirement to 5.8.1
      bump Getopt::Long
      rebuild meta
      1.7038
      Merge pull request #468 from shoichikaji/try-git-uri-first
      comment
      Revert "fix tests to work with the MakeMaker runtime workaround"
      narrow the scope of EUMM requirement softening only when Module::Install 
exists
      fix the test for Module::Install based mymeta
      1.7039

gregor herrmann (1):
      Imported Upstream version 1.7039

-----------------------------------------------------------------------

No new revisions were added by this update.

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-perl/packages/cpanminus.git

_______________________________________________
Pkg-perl-cvs-commits mailing list
Pkg-perl-cvs-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-perl-cvs-commits

Reply via email to