This is an automated email from the git hooks/post-receive script.

carnil pushed a change to annotated tag upstream/1.6611
in repository libstatistics-basic-perl.

        at  00c0109   (tag)
   tagging  95cec17ffc380b85589d3cf97fac91ac1c5ae0fe (commit)
  replaces  upstream/1.6607
 tagged by  Salvatore Bonaccorso
        on  Sun Jul 26 15:24:53 2015 +0200

- Log -----------------------------------------------------------------
Upstream version 1.6611

Anon (1):
      https://rt.cpan.org/Ticket/Display.html?id=74155

Paul Miller (360):
      mmm git
      making this a bit more modern
      more updates
      started adding overloaders and cleaning house a bit
      I added a todo to cover the things I just started ...
      added many more s/no/use/ warnings
      stripped off a bunch of shitty nonsense docs
      more shit
      whitespace
      whitespace
      I couldn't get the overloader class to work ...
      ipres
      more todo and some re-writes/updates, etc
      we won't be doing this because the new(vector,size) style makes more sense
      ok, I think these tests and overloads are finalized
      gar, spellcheck
      now split-jumps will work
      mode seems all done, curious choice for first to complete
      makefile.old, scalar::util
      did mean and median too
      orien wrote part of this?
      mmm tastey
      overloads for stddev
      vector is all set I think
      order
      the modifications to covariance caused test failures
      I rewrote the tests a little, thinking about the new vector attribute 
support
      I made huge changes to the vector object
      I tested much of the new Vector stuff
      so many changes...
      moving toward that beautiful-er arrangement
      k, mean and variance are both awesome
      did the same cool things to stddev and variance
      tested the new cool things also
      fixed the weaken() code
      did the first-col stuff to median and mode
      we need the computers in covariance to use our new cool style, but 
clearly the computer for variance depends on which other vector it is paired 
with...
      described the last commit
      renamed CoVariance to Covariance
      typo
      the tests were wrong since we fix_size on the unshift end now
      forgot to add this get_linked ...
      taught covariance to return both sizes
      started adapting Correlation to the new layout
      typo
      I lost a couple lines from 0.42 that really shouldn't have been lost.  
Perhaps the git import from CVS didn't go so well?  Odd.
      I updated LSF with the latest layout stuff
      better and more shortcuts
      fixed shortcut exports
      this is better I think
      tested a bunch more stuff in t/07
      this has come quite a ways, but there's a bunch of test problems in t/53 
co
      more tests (that fail)
      more debugging messages
      more verbose debugging messages
      whitespace
      more debugging and changes that make no difference at all
      I added all kinds of cool debugging before I found the really stupid bug 
(next commit)
      grrz, what a stupid bug
      completed the tests
      fixed a bunch of problems with testing while debugging is on
      completed many todos and added a couple others
      new version and merged changelogs
      I think the basic/Basic pod is complete-ish
      documented those latest changes
      couple basic changes
      minor doc changes
      this documentation is barely acceptable, but better, somehow, than the 
original
      typo
      did the doc for correlation
      topos
      typo
      wrote up a nice Cov pod
      these are empty
      while documenting variance (done) I noticed typos in these others
      did stddev
      typos
      did mode
      typos and docs
      documented vectors
      this is fine... my bad
      paranoid I guess
      forgot some stuff
      from the docs
      cranked out the insert/set stuff
      hammered out a couple more todos
      noted the docs
      I found a bunch of typos already, starting the proofreading over from the 
top.
      more doc fixes and the new x_given_y and y_given_x functions
      more whitespace
      little doc fixes
      moved a bunch of shit around
      grrz
      doc fix
      typo
      doc fixes
      added a readme
      isa() is smarter than ref() because ref() may not match a correct isa()
      cvec is happening!!
      this will work shortly I hope
      new version
      documented the 1.5 version
      self defined computers is better than a new class
      awesome, the filtered vectors rock
      lawl, the new filters rock
      missed the new pod
      whitepsace
      I did some cleanup on the recalc code, but still can't account for the 
vile test failure in t/08_filter*
      fixed median bug
      forgot to version up, as usual
      n::f and abs(-1) patches
      this is pretty hot
      this will work more reliably now that the tolerances are installed I 
imagine, but we need to actually test it.
      when there are math::bigthings in the vectors, overload freaks out with 
the lhs in s::b and the rhs in m::bt
      talked about bigint in the changelog
      failed to remove debugging note
      these dot ohs were for bignum (didn't help)
      this test is hard to get working
      moved the exists() to compile time
      installed a typo
      I put the 'eq' function back
      wow, cut and paste accidents
      moved tollerance before compile of use S::B
      described this new compile time requirement
      whitespace, non math::, etc
      insert notification got promoted to debug=1
      I was really thinking about the blessed() check incorrectly
      this is releasable... I'm going to wait to see if I hear back from 
William R. Ward first though
      forgot to manifest the t/60 M::BF test
      reply to rating
      better note
      fix the t/60 failures?
      require NF 1.61
      version mismatch
      this didn't help, but I didn't want to throw out the code...
      bye bye
      1.6003
      bug found by Raj Chandran <rchand...@nextrials.com>
      little cleanup
      meta yml stuff
      fixed manifest bugs
      typo
      meta.yml patches
      fixed copyright information by request
      docbug
      never finished my thought...
      documented docbugs
      5.8.1 is actually required for this module... might work in earlier 
perls, but *NOT* 5.8.0
      this test is going to be awesome
      instead of freaking out when there are undefs, print them with sanity
      ok, so these are highly correlated even though there's missin data...
      new help function named
      document new feature(s)
      call it what people actually call it
      version bump
      add best practices tests to the dist
      note additional tests
      bump version for new shit
      renamed all the recalcs
      lose the warnings for early stringifications
      made ginsert grow instead of setting the size
      Made a ton of doc changes to satisfy pod_coverage.t (plus some
      if I can DRY Correlation, then Covariance is next.
      rename twovector package
      use eval so errors burp up in the caller
      it was harder than expected to make these truly DRY by using a baseclass, 
but they seem to work now
      renamed base class
      DRY progress notes
      pod for two vector base
      manifest the new pod
      move this stuff to the base m odule
      decided to include this afterall
      moved query to the _TVB
      LSF using _TVB
      doc bugs
      doc bugs
      built the better pod for cov
      the Mean conversion to a base package went flawlessly
      ws
      too correlation-centric
      I began working on the conversion of Mean to _OVB, and noticed tons of 
POD issues
      add norm
      change this language, which is wrong... combe back in a bit
      renaming normalize ... nofil
      query_filled
      query_filled test
      document the fill disabler (changes)
      facilitate using vectors that can be less filled than their max size and 
respond with undef when used
      more query_filled stuff
      had a lotta stuff tracking that I didn't really need to track
      note the removal of the functions from LSF
      FILL and NOFILL
      return objects from accessors
      return objects from accessors
      this test doesn't work at all
      manifest the moving average test
      moving average test
      eh
      _OVBed Mode
      converted median to _ovb
      fixed some debugging bugs
      _OVBed: StdDev, Variance
      bugs introduced by base-classing
      (full details)--
      worked on the pods quite a lot
      a lot of these shall not be documented and threfore, should be marked 
private
      note new changes
      started fixing the privates
      for consistancy, size() should be query_size(), jesus
      size -> query_size
      note changes
      epic fail at renaming these previously
      finish fixing the privates (?)
      working on the pods a bit
      these pods are getting to be a nightmare, what can ya do
      more pod stuff
      more pods
      more renamings
      made another accessor return the object
      changed ginsert to append in the docs, and changed a couple things
      note changes
      failed to bring my critic config over from Net::IMAP::Simple
      failed to mainfest the rc
      altered whitespace
      ginsert vs append
      trying to make things really consistent
      completed the docs for vector
      I *just* noticed leftover pod_coverage trustmes from PJF, hehe
      typo
      might be re-designing computed vectors very slightly so  = 
computed(1,2,3)->insert(4) will work
      return the object for these accessors
      I screwed this up I guess
      append
      ws
      I actually made all these do something though, so this was academic
      altered whitespace
      Superfluous
      fixed copy
      note changes
      note to self
      taught this to understand set_vector from computed vectors
      taught this that it's wrong to do what I taught it last
      noted autofill stuff
      did some of the computed() docs
      typo
      make the dates a lot less specific... I've been ignoring the times anyway
      this stuff is hard to keep track of
      extra space
      note that you can affect the contents, but shouldn't
      use stronger language to discourage changing the ref
      copy vectors instead of linking them.  Computed vectors can serve this 
role, and it makes little sense to do this with regular vectors
      note changes
      this should always work now, or it's probably a bug
      make accessors return the object
      this stuff all checks out
      note changes
      Basic.pm [critic.t]
      ComputedVector.pm [critic.t]
      Covariance.pm [critic.t]
      tons more [critic.t] changes
      end of [critic.t] changes
      continue making sure query refs stay the same under various transforms
      since we copy instead of link, I think it *will* do what we want now
      test the set_vector vs query_vector (ref) stuff on computed vectors
      I think these docs are correct and complete
      todo
      note
      note append vs ginsert
      allow set_vector(1,2,3,4)
      all these objects should be true if asked
      take nonscalar arguments that look like numbers
      use the nonscalar set_vector and the new bool overloads
      note changes
      more places to use the new bool context overload
      made this pass tests using the new set_vector
      strip useless spam
      major bug, introduced in the set_vector(@_) epoch
      no uninitizlied warnings.  undefs are allowed.
      there's no real reason the elements have to be numbers
      last night, I re-did this test a little so I could see what was coming 
back instead of a boring fail
      a new test to find warnings and size failures on construction
      note changes
      make these more descriptive so its easier to see which object is fail 
(all so far)
      fix initialization bugs
      remove debug msg
      fixed up the LSF docs to pass pod_coverage
      k, these docs are ready for public consumption I think.
      note about new
      new test that shows oddball warnings
      less vertical when applicable
      less vertical when applicable
      add tags to computed vectors so they work in the various objects that get 
linked computers for two vector computations
      add query_vector
      I think the CV is ready
      use B<> instead of C<> for =items
      made the overload txt really consistent
      note chaining
      TODO REFORMAT
      debug typo
      the pods are coming along, so tedious.
      introducing rand() to tests makes the tests fail sometimes
      use chaining
      provided an interface to the ENV vars without having to interact
      critic bug
      trying to eliminate the ENV vars alltogether
      note changes
      this is annoyingly difficult
      removed ENV crap
      must load base modules later
      use qw(toler) rather than ENV{TOLER}
      leftover debug
      rework tests to avoid ENV (mostly)
      new critic problems ... shhhhh
      that was a lot of documentation to change, but I think it's all set
      fixed the rest of the docs too
      pod todo updates
      Mean seems ok
      couple little things
      did a few more pods...
      did a couple more pods... tedious
      pods, tedious
      I'm tired of updating this
      this should be all of it
      pod bugs
      note changes
      English bugs
      little doc changes for readability
      typo
      additional notes
      lists, not arrays ... probably
      doc change
      make the line of fit way more easy to understand and deal with
      handle_missing alias
      one more test
      allow 5.6.x, not that it helps
      ignore this stuff (updates)
      don't set TEST_AUTHOR, when you're not the author, and then complain to 
me about the problems you have.
      grrz
      I happen to like it.  Until perl itself removes this, why should I?
      stfu
      fixed actual problem
      resurrect 5.6.1
      https://rt.cpan.org/Ticket/Display.html?id=65065
      https://rt.cpan.org/Ticket/Display.html?id=65065 (continued)
      version bump
      updated this so people know which version.
      ignore this stuff (updates)
      minor tweak
      it's 2012 now?
      update copyright and add note about Statistics::Descriptive
      version up for re-release
      bug
      version
      LC_ALL=C
      Revert "LC_ALL=C"
      locale hack to pass tests that assume 22/7 is 3.142 and not 3,142
      ignore this stuff (updates)
      ahh, I think this is what we want
      Merge branch 'RT100943' of https://github.com/eserte/statistics--basic
      oops

Salvatore Bonaccorso (1):
      Imported Upstream version 1.6611

Slaven Rezic (1):
      a workaround for RT #100943

jettero (4):
      Initial revision
      ok
      ok
      ok

-----------------------------------------------------------------------

No new revisions were added by this update.

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/pkg-perl/packages/libstatistics-basic-perl.git

_______________________________________________
Pkg-perl-cvs-commits mailing list
Pkg-perl-cvs-commits@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-perl-cvs-commits

Reply via email to