This is an automated email from the git hooks/post-receive script.

fsfs pushed a change to branch master
in repository libnet-imap-simple-perl.

      from  7945128   update changelog
       new  ef71c09   Add debian/upstream/metadata
       new  5cf0065   Update debian/changelog
      adds  145e2dc   the original 1.17 release
      adds  cdf3f04   my first unseen() patch
      adds  b17a8eb   my msg_flags and initial put patches
      adds  6621285   corion's starttls patch
      adds  b2f5478   warning about a huseless somethin hash, blah blah
      adds  adf5b54   flags bug patch
      adds  8e0399a   moving a few things around
      adds  29ef287   die rcs die
      adds  51820a8   I pulled these from pjf's IPC::System::Simple
      adds  ad13498   I stripped the pods off, now to strip the code 
from Simple.pod...
      adds  b3007a8   stripped the code off the pod
      adds  30a8741   critic patches
      adds  005b5e4   This is a combination of critic suggestions and the 
disabling of some Corion debugphilic code.
      adds  6390322   fixed a few pod problems and word-wrapped a bit
      adds  742b7aa   fixed introduced bug
      adds  85e53c9   made the pod_coverae pass
      adds  d74d07e   worked on the README a bit
      adds  1882933   my todolist, devtodo
      adds  189dec6   woops, screwed up the manifests
      adds  afe425a   forgot to skip itself
      adds  05ab743   test is born unto me
      adds  82b67ef   made some progress on the test file and instructed skips 
for the makefile
      adds  da95e50   more birthing of teh imap server test
      adds  18f2a4c   MANIFEST
      adds  675b150   the certs
      adds  fb44848   this is about as close as I can get without building auth 
and model classes
      adds  14da21e   auth and model skeletons
      adds  fd34631   catch sigchild during startup
      adds  497e848   fixed startup
      adds  3178c89   made Net::IMAP::Simple::SSL totally un-necessary, if it 
ever was
      adds  a7236a7   documented the use_ssl flag and fixed up a bunch of POD 
stuff and mispellings
      adds  c4b4aa9   made the use_ssl flag more robust without requring 
IO::Socket::SSL at configure time
      adds  d3d7f55   altered whitespace
      adds  0e9b60d   this was pretty confusing in the debug log
      adds  4eb60bb   made the debugger print less superfluous info
      adds  55ee24e   have to decide to use the funny port before we select the 
      adds  d394aa6   note changes
      adds  66f6619   version up
      adds  103e1b1   fail tests unless select works.
      adds  d1b210f   make 0 message 0, but true
      adds  effdd2e   fail loudly, should we do this everywhere?
      adds  5257b83   you need to tell perlcritic to be critical... I didn't 
know that.
      adds  6c827e5   after making the critic critical, some changes were 
      adds  9928123   the logs show this put() is working, ... o rly? where did 
the mail go?
      adds  e32399b   little typo
      adds  a9fd65c   woops, should be require, not use\!
      adds  dc02398   working on getting the tests to go, found some minor bugs
      adds  02b2138   I think when this test does more stuff I'll release as 
      adds  d8a50dc   point out bug queue
      adds  36f08bf   this is my little login function
      adds  a6a112f   wow, the manifest was really jacked, wonder when I fat 
fingered that
      adds  3aaf6d7   bugs
      adds  eebaeaa   hrm, I think I fixed the oldest bug on rt ...
      adds  8662750   a little note to myself
      adds  9da109f   I borked ->last
      adds  387366f   k, this stuff seems to be working right
      adds  9aaedec   document the bug I created, and fixed
      adds  7fbfc51   skip
      adds  c814e04   moved the tests around a little
      adds  ef468af   manifest changes
      adds  575f27f   making the server start-up, run tests, server down at end
      adds  f63a31e   make it easier to run one test at a time
      adds  fa6ae24   different mailbox
      adds  57cd048   this is telling
      adds  7e84320   dividing up the tests sucks
      adds  789c52c   moved things around a bit to verify something
      adds  c2957c4   found a new way to prevent DRY in the tests
      adds  59c85aa   I don't understand why this exit-value is non-zero, but 
I'm blaming threads.
      adds  9b3e669   the final test might be something like this, ...
      adds  e88fd24   there, now the test can start and stop itself, without 
using signals...
      adds  401fd80   new release plan
      adds  50fd764   _process_cmd -- should always return a count or undef, 
even in list context
      adds  0fb5a24   going through all the process_cmd calls ...
      adds  810d521   Revert "_process_cmd -- should always return a count or 
undef, even in list context"
      adds  c787af5   make the imap server startup noisy-to-the-right
      adds  a6c5b24   EXAMINE seems easy enough to support... depends on what 
the servers do when you try to put or change the flags after the command
      adds  c0f0216   EXAMINE command
      adds  68458e9   getting ready to test the new() 4-connection ticket on rt
      adds  e1ff05a   well, I don't think Simple can detect *ANY* disconnects 
at all, much less in new()
      adds  a241f34   make it easier to run the server for a while...
      adds  1aba39e   some startup scripts
      adds  eac3fdd   made this startup and shutdown better
      adds  f57e289   testing a few things by hand
      adds  8b8c1e4   made the connectalot script do more stuff
      adds  bd405bf   you can't reliably tell if a socket is closed until you 
try to read from it ... it either blocks until data arrives or returns 0
      adds  37c4ce4   finally, man, that was hard to figure out.
      adds  621ea73   closing 30229
      adds  c5a9e06
      adds  b076c79   started _04
      adds  83e7b45   critic, was critical
      adds  925210b   mmm, all tests failed everywhere because Net::TCP isn't 
core, duh, IO::Socket::INET is though
      adds  d505957   this doesn't work... I have some ideas why, but it's time 
to go skydiving
      adds  0153fd5   the reselect fires now, but something is still wrong.
      adds  a3fdf0b   might have found a bug in Net::IMAP::Server, must look 
into it further.
      adds  2789a98   I had broken t/07 when I added things in t/15
      adds  de0b458   this should close out 45953... I'll prolly write more 
tests for it though
      adds  1d08fb2   note changes
      adds  cbca800   undeleted seems like a natural addition
      adds  b396c5b   more flag tests
      adds  c17bf71   bump version for next tickets
      adds  b8f463b   working on 33189 a little
      adds  3db282a   working on 33189 a little
      adds  c213fe4   33189 info attachment
      adds  bba9c37   oops
      adds  8df6e2c   make these more configurable
      adds  29fc36d   of course, if I'm making it configurable, it should use 
the configs
      adds  21ae96b   ws
      adds  25ff45f   changed the way debugging works on these guys
      adds  274e15b   status precursor
      adds  fd1855f   superfluous
      adds  e52383d   STATUS command
      adds  1e7d98a   755
      adds  1f3544a   status app
      adds  f5095a1   manifest the contribs
      adds  89e8230   this will become the status test
      adds  b4aa683   the working box shouldn't be escaped like that
      adds  b9a3f54   added a current_mailbox test
      adds  ab6175f   haha, bug
      adds  ab05776   I introduced a bug when I unescaped the {working_box}, 
but then thought about it and taught _escape() to not modify the given argument
      adds  be51a2c   bug
      adds  d7cc0a1   these numbers are't matching up, but they should
      adds  4d0651b   moving the t7lib:: to t:: so pause won't index it
      adds  992fee2   move these to inc so they don't get index
      adds  1232ad4   manifest file moves
      adds  bafeca7   described latest patches
      adds  ca78187   temporary fix for Net::IMAP::Server::Mailbox::unseen() 
v1.18 [reported]
      adds  591dd08   ridiculous bug
      adds  6a048aa   ridiculous bug #2
      adds  e2f1c5d   missed this in the manifest somehow
      adds  5e1e5a6   make my t/17 actually do what I wanted it to do 3.5 hours 
      adds  919af78   critic hated my naked comma evaluation, I think it was as 
clear as sitting in parens... whatever
      adds  5a22325   improved docs for seen and unseen
      adds  99530fd   add my 33189 notes to the dist temporarily
      adds  7dc3fce   make the debug logger a little smarter
      adds  5ad904f   deal with errors on msg_flags better, and use msg_flags 
from seen and deleted
      adds  133d70c   expand that test slightly
      adds  4e99036   documented the new flag error code
      adds  746b4f8   documented my thinking for closing 33189
      adds  7e54e7b   require Net::IMAP::Server if we're under AUTOMATED_TESTING
      adds  901f8e5   this aught to test correctly
      adds  e269ee7   trying to get expunge to be a little more informative
      adds  3917253   describe latest changes
      adds  bdb6398   I'm nolonger chaining ->_reselect, so some of the tests 
needed fixing
      adds  b524695   note changes
      adds  aa73e08   test the scalar mode
      adds  8952f0b   this should work fine
      adds  880415e   except that there aren't that many messages ...
      adds  41607fb   ok, this tests almost all the delete stuff I can think of 
(not counting various permutations of failures and successes)
      adds  c08bd64   note about delete working correctly.
      adds  26689ce   I misunderstood the rfc 6.4.3 example
      adds  364febc   copy tests
      adds  9d9c4dd   altered TODOs
      adds  1f8458a   moved the tests around a bit... I can't tell if there's a 
copybug in Net::IMAP::Server or not...
      adds  26af285   sequence sets work just fine
      adds  dc11111   documented RT#40203's concerns
      adds  f92a229   my message body precursor
      adds  17e7eb5   I changed the way get() works.  I'm pretty much going to 
have to undo it tomorrow though -- it'll bork everyone's code
      adds  503aae3   comprimise between $message = $imap->get(1) string and 
arrayref (do both)
      adds  5080ba5   printing 40 spaces will prolly fail more than just using 
console codes...
      adds  af242e6   prove that our _process_cmd is a failure
      adds  90c4400   JIK's patch attached to RT#33925
      adds  44f616e   catch the line even on misbehaving servers that don't CRLF
      adds  1a1081a   note the application of the patch
      adds  820d791   lose 33189 txts
      adds  6876245   couple little pod tweaks
      adds  87e2cc2   1.1900
      adds  b59b4b0   explicitly include all modules needed for the tests
      adds  4ea70c9   note changes
      adds  a629032   this is a bug, woops
      adds  afd675c   include static copy of net-imap-server-1.20
      adds  a422bfc   going to release this
      adds  b3240d1   failed to actually use the inc/ copy of 
Net::IMAP::Server, coder == fail
      adds  1bc96dd   optionally disable the inc copy
      adds  4decba7   make sure to show what version of the imap server we 
      adds  26558d9   BP's 1.22 with patch
      adds  62f4680   1.22 n-i-server included
      adds  19355c2   trying to deal with test failures from the 
cpan-testers... Class::Accessor missing, weird
      adds  f51f87f   ignore this stuff (updates)
      adds  b179404   my test script
      adds  a78040a   my dovecot-pipe-server-thingy -- OK -> PREAUTH
      adds  b70946c   fix for
      adds  031275d   versionup
      adds  bc70947   really weak search command
      adds  ed2a49b   misunderstood how the search result comes back
      adds  7b8610a   I think we can do better, noted
      adds  c51f1c6   goal
      adds  037e3c3   implementation
      adds  2639836   mention the need for tests for top(), but don't actually 
do work
      adds  6d57a7f   accidentally killed manifest, fixed
      adds  32b218b   can't really publish this without docs. :)
      adds  03c61c3   PATCH FOR
      adds  9771c25   we can get a lot less set errors if we just mark these 
lines we don't parse as boring
      adds  328bc51   fix for perl critic
      adds  17a606d   filling out search a bit more
      adds  7668390   likely, a lot of these functions work...
      adds  11ccc3a   failed to quote quoted strings
      adds  e57d1a4   I misunderstood the date comments in the RFC3501 search 
      adds  0d13424   added pod
      adds  4e72d58   added pod
      adds  0fdd491   these really need "spaces"
      adds  05ed9ca   this I had jacked this up pretty bad -- git bisect ftw
      adds  559182c   this is a quick cut and paste from t/15_flags.t
      adds  43e99e3   this isn't what's advertised in the pod
      adds  7a67b65   got the search tests online, not very thorough, but 
better than nothing
      adds  acd5023   version bump
      adds  292878e   forgot to manifest the new test
      adds  37cd3d6   this is actually necessary for testing, didn't know that
      adds  11b938a   I can't figure out why this test is failing ...
      adds  19481ee   dev-version up for testing
      adds  42e2888   don't dork up the tester reports
      adds  f953bd1   I really just want to test 22 with my tester, separating 
      adds  a92e437   make this ridiculously verbose
      adds  4246510   1.1910_2 ... wtf is going on
      adds  be1f2bb   there is no bug, there is only zuul
      adds  5706873   I think this is what he's asking about
      adds  fab7891   this is a google bug, not an net-imap-simple one
      adds  333ea1b   test for ticket #55552
      adds  f4eba4d   I somewhat recall changing _unescape, oddly enough, but I 
don't think I fixed any of the actual uses of it.  :)
      adds  8e40763   version up for release to fix #55552
      adds  88f1f87   doug reed patch
      adds  029708a   version up to 1912
      adds  faef7fd   Fix a use of _escape in void context
      adds  5c65e05   Escape the mailbox name to APPEND
      adds  7a0a4c7   note changes
      adds  fc5ac4d   Add a way to close SELECT'd or EXAMINE'd maiboxes
      adds  067d230   Add a ->noop method, for sending NOOP commands
      adds  9da7354   merge with a couple more alexmv "monkey" patches
      adds  3b8846a   heh, he had a copule more; version up again
      adds  d817565   shhhh
      adds  5009767   use 1.27
      adds  3ca74d7   note changes and version up
      adds  3a3f0b0   this effectively disables the whole line, meh
      adds  abc7c59   I suspect this is not how alexmv will do it
      adds  2482fc1   Add the ability to sort via search
      adds  9bc7f07   version up
      adds  e7420d1   make a formal server log
      adds  4f69303   pull in a7f5e24 from Net::IMAP::Server
      adds  3ba9bc5   use alester's license section
      adds  1728e49   change the bugs message
      adds  3bc97b2   note that I may not have permission to change the license
      adds  0fb0849   add 2010
      adds  c6c8075   make SimpleX optional
      adds  066bb8f   This is woodwardj's first draft.
      adds  b5961a1   Merge branch 'master' into SimpleX
      adds  66dc150   confusingly, manifest and not manifest simplex
      adds  923978a   provide a way to use simplex from inc/slurp
      adds  b764365   make inc build smarter
      adds  af83ed3   fix package name
      adds  8645d21   this is goign to be fun maybe
      adds  8fb4838   ignore the new test file
      adds  a6d3f29   extended body_field_param production and fixed the 
body_fields definition
      adds  6e7829d   Added part numbers to the data from body_summary
      adds  f2f626e   Extended get() to support fetching a message part
      adds  ed948ca   trailing whitespace
      adds  1dee7b0   added SimpleX pod
      adds  bcea1e7   ws
      adds  61b03ab   pull the pod into the blibs
      adds  f25cfd8   track this, don't track that
      adds  19fb76c   tweaked the synopsis slightly.  I found I had to go check 
the source to see how to invoke simplex, so I described that quick at the top
      adds  f471637   oops, wasn't checking return value correctly
      adds  61ebfdf   for local builds, it's convenient to have some unlink and 
default powers
      adds  26f85ef   skel a body summary test
      adds  d22ff55   heh, gotta ->new() the right package though
      adds  5af7f39   I didn't like the way the body_summary changes shape so 
dramatically between multipart mixed messages and single part messages
      adds  f57e87d   SINGLE part message works great
      adds  3096ced   multipart test
      adds  ab1c9a3   Merge branch 'SimpleX'
      adds  793d96d   version up(s)
      adds  e5b4779   I find myself editing the wrong ones, this'll make vim 
      adds  20b6fd7   make make rebuild the simplex stuff automatically
      adds  4b46e70   tidy up body summary data into BodySummary and Body 
      adds  d825c15   I find myself editing the wrong ones, this'll make vim 
      adds  1dffeb5   content_type vs hasparts
      adds  6897da5   make make rebuild the simplex stuff automatically
      adds  ca0dde7   fixed test
      adds  846c55b   Merge branch 'SimpleX'
      adds  efc9eed   log changes
      adds  79f7282   updated SimpleX pod
      adds  e9fcfb1   new
      adds  62d9415   invocation notes
      adds  9a5db45   I disabled more perl critic stuff rather than do some of 
the more irritating things it suggested
      adds  41f8a8e   holy smokes!  hooray!
      adds  d19b30a   modification of read only variable how?
      adds  e985252   oh, that's right.  This bug still persists -- pfft
      adds  99dd2ec   more debug options
      adds  df9f332   critic "bug"
      adds  d89419a   document and then strip the )\r\n
      adds  83bfed0   irritating
      adds  1bfc7d8   %d-%m-%Y -> %d %b %Y
      adds  fffa0e6   don't select every search, only when we need to
      adds  817287d   it seems the - is FWS and that's what google expects... 
most people seem to use the -, still %b instead of %m though
      adds  6467462   say the right things here
      adds  bf181fd   I don't think last() is quite what I want... I'm playing 
with this idea
      adds  e251fa1   provide uid information
      adds  a1c1b6c   caveat
      adds  635121c   the star isn't a wild card, it means biggest
      adds  be20921   test uid stuff [and fix bug in Search filters]
      adds  32af3e3   critic ; didn't even know this was a magic variable... I 
use $< for that
      adds  fe0f826   this is private, mark it that way
      adds  ae437d5   I wonder if this will make more bugs than it creates... I 
doubt it
      adds  720cf8d   note it
      adds  bce909f   skelled my ideas
      adds  b67bf01   I'm going to write a grammar for this
      adds  44ead76   senseless renaming
      adds  b8a08bc   bug
      adds  5d7b20a   regex abuse detected, but used correctly
      adds  35a760e   partially working
      adds  f55f16e   ahh, there we go
      adds  571f3b4   shhh
      adds  3ece483   Use the grammar please
      adds  6bb18f2   move fetch to sX officially and return something sane
      adds  3f10afd   I think this is coming along, but it still doesn't work 
for some reason
      adds  28eeec0   caps
      adds  83d3c9e   talk about why we failed... NIL? (test) ... fail.
      adds  af1b7a4   I had a lot of fail in this gammar, I think I fixed a lot 
of it
      adds  ef6325e   ok, I think I fixed most things
      adds  2ba8351   learn to count
      adds  a07453c   getting my doc started
      adds  236cdbb   this return style is immediately useful and doesn't 
require post processing
      adds  5b62c8f   actually, it still wasn't quite what I thought.  Fixed
      adds  cdc6fcb   star is allowed
      adds  05f75bc   man, this is just really hard to get right
      adds  112eaef   I clearly don't understand the scoring, because this was 
crashing out another part of the grammar
      adds  10e8ccd   well, if the score won't work, reorder these so the body 
thing matches first
      adds  3fa4acf   also, don't let atoms have [] in them
      adds  8850b81   ignore this stuff (updates)
      adds  b88c71a   took changing the logs around a little to realize 
Net-IMAP-Server gives more than one response per message.  Add reverse() to 
throw away alternate responses
      adds  eae45a1   there, this tests well, I like it
      adds  af24bf2   the x00 type is too wierd to bother people with
      adds  c825323   don't require selecting first
      adds  c0854ea   document my damage
      adds  83f8614   version up
      adds  3acca6c   shh
      adds  948f3d5   maybe more behavior's later
      adds  303eee0   logout method
      adds  99daacb   this might work if it didn't sagfault ... going to look 
for a P::RD official way to do this.  There msut be lexer access or something 
like it.
      adds  e9a3a0f   this is like one million times better
      adds  8098962   sexy fix for the .{32766} RE limitation, in fact, this 
was better all along
      adds  0b33f4d   note changes
      adds  8a0139e   copyuid, and prep for launch
      adds  edb0798   going to make fake sockets that are actually pipes (eg 
ssh host dovecot)
      adds  bd100db   seq() is the opposite of uid()
      adds  a307e82   list2range
      adds  7c28a83   uid fetch
      adds  6748248   test uidfetch
      adds  8821635   test list2range (found bug already)
      adds  dba0b82   show that we can't correclty parse the tag 'BODYSTRUCTURE'
      adds  ff3d071   ws
      adds  ef40c2d   only match BODY when it's not the middle of some other 
      adds  660730f   cover naked method
      adds  086494c   manifest conflict seemed easy to resolve
      adds  ba42ba5   notes
      adds  5d766ee   I did this at work, it's probably the right start
      adds  9c497bf   typo
      adds  410e4f5   just checking
      adds  70a1da1   this is worth doing I think
      adds  726b297   this is going to be neat...
      adds  b9768c2   change the test server port(s)
      adds  9eeb825   uidsearch code, needs docs
      adds  51922e9   doc for uidserach
      adds  ddc7b53   cool, trivial test
      adds  9cc0aea   expand changelog note slightly
      adds  5882b5a   pretty simple, but useful
      adds  c9a008f   use the sequencer
      adds  8892073   typo
      adds  c3c8f3e   hrm, I was fixing something that wasn't initially 
broken... oh wells
      adds  d3c4ba9   this space may make a difference on some imap servers... 
doubtful, but it could happen
      adds  f14e33d   merge was awful... meh
      adds  1ffb97b   this clearly needs a lotta work, but it'll do
      adds  0edb00a   this is the most awesome thing in the world
      adds  66d3480   fixed the err loop
      adds  b574e01   might as well support the
      adds  2801a58   version up for the pipe
      adds  a26b083   mostly fixed this... things aren't so good a little though
      adds  a379964   just trying to figure out where we're freezing up (it's 
in the READLINE)
      adds  903eed7   this all works fine, except that it doesn't
      adds  9cda19c   lawl, blocking forever
      adds  5182200   even better
      adds  cab0b29   note changes
      adds  2f6d4c4   added a test
      adds  ea6f33e   document ps
      adds  6a3c648   critic
      adds  4ed0a1a   skip all of the functions in the pipe socket
      adds  3284268   test and fix for
      adds  b9b5d66   this is where we snag the callback
      adds  3861a15   use the callback, if givin
      adds  72ffb31   testing the readline callbacks
      adds  326aeda   document readline callbacks
      adds  97114fd   [1::2]:3 ipv6 patch
      adds  a547fba   bug
      adds  1e0f15f   bug
      adds  42c7092   possible fix for
      adds  c1121fd   maybe like this..
      adds  59eb3ff   note changes
      adds  be671b3   this is why my tests don't work —
      adds  e226c08   the patch wouldn't apply for me, I made this instead
      adds  7d79d96   version up for release
      adds  801e769   don't manifest this
      adds  c24038d   I don't want to maintain these anymore
      adds  299dbef   subtle doc buc noticed by aka HM 2k
      adds  e6ce092   another subtle doc buc noticed by aka HM 2k
      adds  8c6b535   another subtle doc buc noticed by aka HM 2k
      adds  84247c6   another subtle doc buc noticed by aka HM 2k
      adds  10dae5b   construct test for
      adds  b4d48f7   I'm not sure that test would have functioned correctly
      adds  41e7c7e   this appears to fix
      adds  b1dfced   version up
      adds  5a67e68
      adds  09c1ac4 removed the die()
      adds  d2c0b72   comical little typo that
      adds  043139d   22
      adds  f66b821   Cannot set retry value to zero in constructor 
      adds  a48e344   version up
      adds  705f8b3   MYMETA is news to me
      adds  000c230   sorting within range2ist breaks IMAP sorting via search
      adds  ab9e2db   version up for nosort patch
      adds  5d98d7d   yeah, these make rules screw up dmake (my strawberry 
seems to use nmake, whatever) and aren't really even used ...
      adds  59ecb38   uidsearch+sort does not return uid's but msgno's
      adds  15fbe17   version up
      adds  7e2407c   proposed diff that makes podchecker happier
      adds  e395f3a   skel test that can hopefully reproduce
      adds  fe335c0   yeah, shows the error nicely
      adds  2a1ec5c   version up for fix
      adds  84857bb   crap, this works fine
      adds  fb22ebb   this could potentially fix the problem, but I still don't 
definitely know what it is/was
      adds  f778c5b   ahh, here we go.  This is the error.  It is spurious
      adds  96c6a0d   ok, this almost ceraintly deals with; but I introduced a bug
      adds  6c02ff3   that space wasn't whitespace, it was message body
      adds  c74aa05   oops; if they don't have some of the test modules, this 
will produce three failures
      adds  e03b289   the real version number doesn't have that one
      adds  195e122   add method separator
      adds  3b56999   Merge pull request #1 from kakadoo/master
      adds  1140978   Merge remote-tracking branch 'github/master'
      adds  e4acd57   version up
      adds  b5f83f4   document sep method
      adds  5dbc860   [PATCH] Spelling glitch
      adds  134ea33   version up
      adds  a62fdba   this works... I feel like I should do better
      adds  684de53   note changes and version up
      adds  6bcb640   this is my horrible idea to make sure tests run in 
order... The one second wait per test is the best part
      adds  eb8cf08   note
      adds  0318e67   this should fix most of the test failures
      adds  c365e29   note
      adds  5e65254   add support for specific ssl versions
      adds  c2d5aea   note change
      adds  07691cd   version up
      adds  15f5545   docoment new setting
      adds  7c6063f   huh, 
is true
      adds  3f3a408   minor password bug affecting people who have backslashes 
and quotes in their passwords
      adds  a1c416f   add IO::Socket to test requires
      adds  581bdf6   disabled for 07
      adds  60e68e2   don't make racket about this
      adds  782f44e   not willing to maintain this shit anymore
      adds  2032a41   these too, gone
      adds  88357bc   don't need any of that shit anymore either. :p
      adds  79ea1f2   some out, some in
      adds  0d408be   fixed one test... 85 more to go
      adds  ffac53f   nothing works at all, hurray
      adds  5bc47f9   there we go
      adds  d747723   ugh
      adds  034589a   k k
      adds  0658a81   couple more
      adds  49b1274   dovecot
      adds  4998ba9   not done with this one... might reverse all this shit 
      adds  d92775b   this breaks all local-server tests, and therefore fits 
nicely in this branch
      adds  51b0f95   there, this should help
      adds  cd24e8b   release a dev built
      adds  9dda777   fuck it
      adds  3a901e7   ta
      adds  b74d56d   this breaks all tests, naturally, but should probably 
still be added
      adds  375c6b6   I need to handle this in some rational way
      adds  4f946bf   ssl patches
      adds  24f761a   various merge problems.
      adds  ae5e335   need to actually fix the tests now...
      adds  cf19609   various
      adds  cdc418e   t/15 puts do not give the expected unseen and recent
      adds  c702155   same but better imo
      adds  db28c6c   made a lot of progress there
      adds  c0545d7   docoment the new ssl... considering a warning about 
certificates when not checking with the CA cert database
      adds  13e7c80   found another bug
      adds  56b7c61   recent doesn't work on dovecot like I expected.  If *I* 
put in my *current* session then the message isn't \recent like it is in 
Net::IMAP::Server.  Not too shocking.  We just remove all recent tests and move 
      adds  9cfeecc   there, another one bites the dust
      adds  ca296c0   dovecot recent removed, test fixed
      adds  b5de6b9   another one down
      adds  e48d5a0   hrm, let's just make some mailboxes
      adds  80b50e2   there we go
      adds  0b808c6   finish rebuilding tests for new actual server environment
      adds  260e082   cleaning up some stuff
      adds  0a98e8b   note
      adds  604e878   explain hidden tests
      adds  4785026   minor version change for no real reason, supz cpan
      adds  eb68c10   fix bug in "find_ssl_defaults"
      adds  4c96fa9   bug
      adds  c03c798   new debug function
      adds  c731f83   yeah, ok:
      adds  31dd379   note
      adds  c8c3415   attempt to fix ... doesn't actually 
address problem he's having in the ticket.
      adds  688d4b3   further testing
      adds  de476a2   version up for spurious bug?  awaiting info
      adds  bc48aab   the holborn patch for the count-type response from cyrus
      adds  59235b9   I fail to see how this wasn't a problem before
      adds  00d9244   fixed
      adds  d79d337   Make the end parentheses match more explicit, debug when 
enabled with a better error message
      adds  8af3a7c   Merge pull request #3 from dravster/patch-1
      adds  57f8ec7   partial reversion to reverse introduced bugs
      adds  ee1f44c   disabled errors
      adds  a5fa2cf   Allow port to be set via params to new
      adds  65b24b5   Merge pull request #4 from hoelzro/master
      adds  049cc48   version up
      adds  c78b718   bug
      adds  b699b6d   Imported Upstream version 1.2206
       new  b627aaa   Merge tag 'upstream/1.2206'
       new  5afbba5   Update debian/changelog
       new  fff1393   Bump dh compat to level 9
       new  f9ef701   Declare compliance with Debian Policy 3.9.6
       new  f022731   Mark package autopkgtest-able
       new  6ff2083   prepare changelog for release

The 8 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "adds" were already present in the repository and have only
been added to this reference.

Summary of changes:
 Changes                  |  3 +++
 META.json                |  4 ++--
 META.yml                 |  4 ++--                |  4 ++--
 debian/changelog         | 14 ++++++++++++--
 debian/compat            |  2 +-
 debian/control           |  6 +++---
 debian/upstream/metadata |  5 +++++
 8 files changed, 30 insertions(+), 12 deletions(-)
 create mode 100644 debian/upstream/metadata

Alioth's /usr/local/bin/git-commit-notice on 

Pkg-perl-cvs-commits mailing list

Reply via email to