This is an automated email from the git hooks/post-receive script.

fsfs pushed a change to annotated tag upstream/1.2206
in repository libnet-imap-simple-perl.

        at  375024e   (tag)
   tagging  b699b6da8dccf66407cf35ea6661aacfc555fcce (commit)
  replaces  upstream/1.2205
 tagged by  Florian Schlichting
        on  Tue Dec 1 21:36:29 2015 +0100

- Log -----------------------------------------------------------------
Upstream version 1.2206

Alan Griffiths (1):
      Cannot set retry value to zero in constructor 

Alex Vandiver (4):
      Fix a use of _escape in void context
      Escape the mailbox name to APPEND
      Add a way to close SELECT'd or EXAMINE'd maiboxes
      Add a ->noop method, for sending NOOP commands

ChinaXing(ι™ˆδΊ‘ζ˜Ÿ) (1):
      fix bug in "find_ssl_defaults"

Drav (1):
      Make the end parentheses match more explicit, debug when enabled with a 
better error message

Florian Schlichting (1):
      Imported Upstream version 1.2206

Holger Glaess (1):
      add method separator

JIK (1):

Jason Woodard (1):
      sorting within range2ist breaks IMAP sorting via search

Jason Woodward (7):
      Add the ability to sort via search
      extended body_field_param production and fixed the body_fields definition
      Added part numbers to the data from body_summary
      Extended get() to support fetching a message part
      added SimpleX pod
      tidy up body summary data into BodySummary and Body objects
      updated SimpleX pod

Jonathan Kamens (1):
      JIK's patch attached to RT#33925

Jorge N. via RT (1):
      uidsearch+sort does not return uid's but msgno's


Michael Stevens (1):
      proposed diff that makes podchecker happier

Paul Miller (486):
      the original 1.17 release
      my first unseen() patch
      my msg_flags and initial put patches
      corion's starttls patch
      warning about a huseless somethin hash, blah blah
      flags bug patch
      moving a few things around
      die rcs die
      I pulled these from pjf's IPC::System::Simple
      I stripped the pods off, now to strip the code from 
      stripped the code off the pod
      critic patches
      This is a combination of critic suggestions and the disabling of some 
Corion debugphilic code.
      fixed a few pod problems and word-wrapped a bit
      fixed introduced bug
      made the pod_coverae pass
      worked on the README a bit
      my todolist, devtodo
      woops, screwed up the manifests
      forgot to skip itself
      test is born unto me
      made some progress on the test file and instructed skips for the makefile
      more birthing of teh imap server test
      the certs
      this is about as close as I can get without building auth and model 
      auth and model skeletons
      catch sigchild during startup
      fixed startup
      made Net::IMAP::Simple::SSL totally un-necessary, if it ever was
      documented the use_ssl flag and fixed up a bunch of POD stuff and 
      made the use_ssl flag more robust without requring IO::Socket::SSL at 
configure time
      altered whitespace
      this was pretty confusing in the debug log
      made the debugger print less superfluous info
      have to decide to use the funny port before we select the port
      note changes
      version up
      fail tests unless select works.
      make 0 message 0, but true
      fail loudly, should we do this everywhere?
      you need to tell perlcritic to be critical... I didn't know that.
      after making the critic critical, some changes were required
      the logs show this put() is working, ... o rly? where did the mail go?
      little typo
      woops, should be require, not use\!
      working on getting the tests to go, found some minor bugs
      I think when this test does more stuff I'll release as 1.19
      point out bug queue
      this is my little login function
      wow, the manifest was really jacked, wonder when I fat fingered that
      hrm, I think I fixed the oldest bug on rt ...
      a little note to myself
      I borked ->last
      k, this stuff seems to be working right
      document the bug I created, and fixed
      moved the tests around a little
      manifest changes
      making the server start-up, run tests, server down at end
      make it easier to run one test at a time
      different mailbox
      this is telling
      dividing up the tests sucks
      moved things around a bit to verify something
      found a new way to prevent DRY in the tests
      I don't understand why this exit-value is non-zero, but I'm blaming 
      the final test might be something like this, ...
      there, now the test can start and stop itself, without using signals...
      new release plan
      _process_cmd -- should always return a count or undef, even in list 
      going through all the process_cmd calls ...
      Revert "_process_cmd -- should always return a count or undef, even in 
list context"
      make the imap server startup noisy-to-the-right
      EXAMINE seems easy enough to support... depends on what the servers do 
when you try to put or change the flags after the command
      EXAMINE command
      getting ready to test the new() 4-connection ticket on rt
      well, I don't think Simple can detect *ANY* disconnects at all, much less 
in new()
      make it easier to run the server for a while...
      some startup scripts
      made this startup and shutdown better
      testing a few things by hand
      made the connectalot script do more stuff
      you can't reliably tell if a socket is closed until you try to read from 
it ... it either blocks until data arrives or returns 0
      finally, man, that was hard to figure out.
      closing 30229
      started _04
      critic, was critical
      mmm, all tests failed everywhere because Net::TCP isn't core, duh, 
IO::Socket::INET is though
      this doesn't work... I have some ideas why, but it's time to go skydiving
      the reselect fires now, but something is still wrong.
      might have found a bug in Net::IMAP::Server, must look into it further.
      I had broken t/07 when I added things in t/15
      this should close out 45953... I'll prolly write more tests for it though
      note changes
      undeleted seems like a natural addition
      more flag tests
      bump version for next tickets
      working on 33189 a little
      working on 33189 a little
      33189 info attachment
      make these more configurable
      of course, if I'm making it configurable, it should use the configs
      changed the way debugging works on these guys
      status precursor
      STATUS command
      status app
      manifest the contribs
      this will become the status test
      the working box shouldn't be escaped like that
      added a current_mailbox test
      haha, bug
      I introduced a bug when I unescaped the {working_box}, but then thought 
about it and taught _escape() to not modify the given argument
      these numbers are't matching up, but they should
      moving the t7lib:: to t:: so pause won't index it
      move these to inc so they don't get index
      manifest file moves
      described latest patches
      temporary fix for Net::IMAP::Server::Mailbox::unseen() v1.18 [reported]
      ridiculous bug
      ridiculous bug #2
      missed this in the manifest somehow
      make my t/17 actually do what I wanted it to do 3.5 hours ago
      critic hated my naked comma evaluation, I think it was as clear
      improved docs for seen and unseen
      add my 33189 notes to the dist temporarily
      make the debug logger a little smarter
      deal with errors on msg_flags better, and use msg_flags from seen and 
      expand that test slightly
      documented the new flag error code
      documented my thinking for closing 33189
      require Net::IMAP::Server if we're under AUTOMATED_TESTING
      this aught to test correctly
      trying to get expunge to be a little more informative
      describe latest changes
      I'm nolonger chaining ->_reselect, so some of the tests needed fixing
      note changes
      test the scalar mode
      this should work fine
      except that there aren't that many messages ...
      ok, this tests almost all the delete stuff I can think of (not counting 
various permutations of failures and successes)
      note about delete working correctly.
      I misunderstood the rfc 6.4.3 example
      copy tests
      altered TODOs
      moved the tests around a bit... I can't tell if there's a copybug in 
Net::IMAP::Server or not...
      sequence sets work just fine
      documented RT#40203's concerns
      my message body precursor
      I changed the way get() works.  I'm pretty much going to have to undo it 
tomorrow though -- it'll bork everyone's code
      comprimise between $message = $imap->get(1) string and arrayref (do both)
      printing 40 spaces will prolly fail more than just using console codes...
      prove that our _process_cmd is a failure
      catch the line even on misbehaving servers that don't CRLF
      note the application of the patch
      lose 33189 txts
      couple little pod tweaks
      explicitly include all modules needed for the tests
      note changes
      this is a bug, woops
      include static copy of net-imap-server-1.20
      going to release this
      failed to actually use the inc/ copy of Net::IMAP::Server, coder == fail
      optionally disable the inc copy
      make sure to show what version of the imap server we loaded
      BP's 1.22 with patch
      1.22 n-i-server included
      trying to deal with test failures from the cpan-testers... 
Class::Accessor missing, weird
      ignore this stuff (updates)
      my test script
      my dovecot-pipe-server-thingy -- OK -> PREAUTH
      fix for
      really weak search command
      misunderstood how the search result comes back
      I think we can do better, noted
      mention the need for tests for top(), but don't actually do work
      accidentally killed manifest, fixed
      can't really publish this without docs. :)
      we can get a lot less set errors if we just mark these lines we don't 
parse as boring
      fix for perl critic
      filling out search a bit more
      likely, a lot of these functions work...
      failed to quote quoted strings
      I misunderstood the date comments in the RFC3501 search specification
      added pod
      added pod
      these really need "spaces"
      this I had jacked this up pretty bad -- git bisect ftw
      this is a quick cut and paste from t/15_flags.t
      this isn't what's advertised in the pod
      got the search tests online, not very thorough, but better than nothing
      version bump
      forgot to manifest the new test
      this is actually necessary for testing, didn't know that
      I can't figure out why this test is failing ...
      dev-version up for testing
      don't dork up the tester reports
      I really just want to test 22 with my tester, separating these
      make this ridiculously verbose
      1.1910_2 ... wtf is going on
      there is no bug, there is only zuul
      I think this is what he's asking about
      this is a google bug, not an net-imap-simple one
      test for ticket #55552
      I somewhat recall changing _unescape, oddly enough, but I don't think I 
fixed any of the actual uses of it.  :)
      version up for release to fix #55552
      doug reed patch
      version up to 1912
      note changes
      merge with a couple more alexmv "monkey" patches
      heh, he had a copule more; version up again
      use 1.27
      note changes and version up
      this effectively disables the whole line, meh
      I suspect this is not how alexmv will do it
      version up
      make a formal server log
      pull in a7f5e24 from Net::IMAP::Server
      make SimpleX optional
      This is woodwardj's first draft.
      use alester's license section
      change the bugs message
      note that I may not have permission to change the license
      Merge branch 'master' into SimpleX
      confusingly, manifest and not manifest simplex
      provide a way to use simplex from inc/slurp
      make inc build smarter
      fix package name
      this is goign to be fun maybe
      ignore the new test file
      add 2010
      trailing whitespace
      pull the pod into the blibs
      track this, don't track that
      tweaked the synopsis slightly.  I found I had to go check the source to 
see how to invoke simplex, so I described that quick at the top
      oops, wasn't checking return value correctly
      for local builds, it's convenient to have some unlink and default powers
      skel a body summary test
      heh, gotta ->new() the right package though
      I didn't like the way the body_summary changes shape so dramatically 
between multipart mixed messages and single part messages
      SINGLE part message works great
      multipart test
      Merge branch 'SimpleX'
      version up(s)
      I find myself editing the wrong ones, this'll make vim complain
      content_type vs hasparts
      make make rebuild the simplex stuff automatically
      I find myself editing the wrong ones, this'll make vim complain
      make make rebuild the simplex stuff automatically
      fixed test
      Merge branch 'SimpleX'
      log changes
      invocation notes
      I disabled more perl critic stuff rather than do some of the more 
irritating things it suggested
      holy smokes!  hooray!
      modification of read only variable how?
      oh, that's right.  This bug still persists -- pfft
      more debug options
      critic "bug"
      document and then strip the )\r\n
      %d-%m-%Y -> %d %b %Y
      don't select every search, only when we need to
      it seems the - is FWS and that's what google expects... most people seem 
to use the -, still %b instead of %m though
      say the right things here
      I don't think last() is quite what I want... I'm playing with this idea
      provide uid information
      the star isn't a wild card, it means biggest
      test uid stuff [and fix bug in Search filters]
      critic ; didn't even know this was a magic variable... I use $< for that
      this is private, mark it that way
      I wonder if this will make more bugs than it creates... I doubt it
      note it
      skelled my ideas
      I'm going to write a grammar for this
      senseless renaming
      regex abuse detected, but used correctly
      partially working
      ahh, there we go
      Use the grammar please
      move fetch to sX officially and return something sane
      I think this is coming along, but it still doesn't work for some reason
      talk about why we failed... NIL? (test) ... fail.
      I had a lot of fail in this gammar, I think I fixed a lot of it
      ok, I think I fixed most things
      learn to count
      getting my doc started
      this return style is immediately useful and doesn't require post 
      actually, it still wasn't quite what I thought.  Fixed
      star is allowed
      man, this is just really hard to get right
      I clearly don't understand the scoring, because this was crashing out 
another part of the grammar
      well, if the score won't work, reorder these so the body thing matches 
      also, don't let atoms have [] in them
      ignore this stuff (updates)
      took changing the logs around a little to realize Net-IMAP-Server gives 
more than one response per message.  Add reverse() to throw away alternate 
      there, this tests well, I like it
      the x00 type is too wierd to bother people with
      don't require selecting first
      document my damage
      version up
      maybe more behavior's later
      logout method
      this might work if it didn't sagfault ... going to look for a P::RD 
official way to do this.  There msut be lexer access or something like it.
      this is like one million times better
      sexy fix for the .{32766} RE limitation, in fact, this was better all 
      note changes
      copyuid, and prep for launch
      going to make fake sockets that are actually pipes (eg ssh host dovecot)
      seq() is the opposite of uid()
      uid fetch
      test uidfetch
      test list2range (found bug already)
      show that we can't correclty parse the tag 'BODYSTRUCTURE'
      only match BODY when it's not the middle of some other word.
      cover naked method
      manifest conflict seemed easy to resolve
      I did this at work, it's probably the right start
      just checking
      this is worth doing I think
      this is going to be neat...
      change the test server port(s)
      uidsearch code, needs docs
      doc for uidserach
      cool, trivial test
      expand changelog note slightly
      pretty simple, but useful
      use the sequencer
      hrm, I was fixing something that wasn't initially broken... oh wells
      this space may make a difference on some imap servers... doubtful, but it 
could happen
      merge was awful... meh
      this clearly needs a lotta work, but it'll do
      this is the most awesome thing in the world
      fixed the err loop
      might as well support the
      version up for the pipe
      mostly fixed this... things aren't so good a little though
      just trying to figure out where we're freezing up (it's in the READLINE)
      this all works fine, except that it doesn't
      lawl, blocking forever
      even better
      note changes
      added a test
      document ps
      skip all of the functions in the pipe socket
      test and fix for
      this is where we snag the callback
      use the callback, if givin
      testing the readline callbacks
      document readline callbacks
      [1::2]:3 ipv6 patch
      possible fix for
      maybe like this..
      note changes
      this is why my tests don't work β€”
      the patch wouldn't apply for me, I made this instead
      version up for release
      don't manifest this
      I don't want to maintain these anymore
      subtle doc buc noticed by aka HM 2k
      another subtle doc buc noticed by aka HM 2k
      another subtle doc buc noticed by aka HM 2k
      another subtle doc buc noticed by aka HM 2k
      construct test for
      I'm not sure that test would have functioned correctly
      this appears to fix
      version up removed the die()
      comical little typo that
      version up
      MYMETA is news to me
      version up for nosort patch
      yeah, these make rules screw up dmake (my strawberry seems to use nmake, 
whatever) and aren't really even used ...
      version up
      skel test that can hopefully reproduce
      yeah, shows the error nicely
      version up for fix
      crap, this works fine
      this could potentially fix the problem, but I still don't definitely know 
what it is/was
      ahh, here we go.  This is the error.  It is spurious
      ok, this almost ceraintly deals with; but I introduced a bug
      that space wasn't whitespace, it was message body
      oops; if they don't have some of the test modules, this will produce 
three failures
      the real version number doesn't have that one
      Merge pull request #1 from kakadoo/master
      Merge remote-tracking branch 'github/master'
      version up
      document sep method
      version up
      this works... I feel like I should do better
      note changes and version up
      this is my horrible idea to make sure tests run in order... The one 
second wait per test is the best part
      this should fix most of the test failures
      add support for specific ssl versions
      note change
      version up
      docoment new setting
      huh, is true
      minor password bug affecting people who have backslashes and quotes in 
their passwords
      add IO::Socket to test requires
      disabled for 07
      don't make racket about this
      not willing to maintain this shit anymore
      these too, gone
      don't need any of that shit anymore either. :p
      some out, some in
      fixed one test... 85 more to go
      nothing works at all, hurray
      there we go
      k k
      couple more
      not done with this one... might reverse all this shit though
      there, this should help
      release a dev built
      fuck it
      this breaks all tests, naturally, but should probably still be added
      this breaks all local-server tests, and therefore fits nicely in this 
      I need to handle this in some rational way
      ssl patches
      various merge problems.
      need to actually fix the tests now...
      t/15 puts do not give the expected unseen and recent
      same but better imo
      made a lot of progress there
      docoment the new ssl... considering a warning about certificates when not 
checking with the CA cert database
      found another bug
      recent doesn't work on dovecot like I expected.  If *I* put in my 
*current* session then the message isn't \recent like it is in 
Net::IMAP::Server.  Not too shocking.  We just remove all recent tests and move 
      there, another one bites the dust
      dovecot recent removed, test fixed
      another one down
      hrm, let's just make some mailboxes
      there we go
      finish rebuilding tests for new actual server environment
      cleaning up some stuff
      explain hidden tests
      minor version change for no real reason, supz cpan
      new debug function
      yeah, ok:
      attempt to fix ... 
doesn't actually address problem he's having in the ticket.
      further testing
      version up for spurious bug?  awaiting info
      I fail to see how this wasn't a problem before
      Merge pull request #3 from dravster/patch-1
      partial reversion to reverse introduced bugs
      disabled errors
      Merge pull request #4 from hoelzro/master
      version up

Rob Hoelz (1):
      Allow port to be set via params to new

gregor herrmann (1):
      Spelling glitch

holborn (1):
      the holborn patch for the count-type response from cyrus


No new revisions were added by this update.

Alioth's /usr/local/bin/git-commit-notice on 

Pkg-perl-cvs-commits mailing list

Reply via email to