Package: bundler
Version: 1.17.3-3
Severity: serious

While upgrading from stretch to buster I noticed this error with bundler and bundler command failed.

NoMethodError: undefined method `message_with_trees' for #<Molinillo::VersionConflict:0x0000559d95ce0698>

This was resolved by updating ruby-molinillo from buster.

Currently ruby-bundler declares ruby-molinillo (>= 0.4.5~) it should be updated to >= 0.6~

# Error Report

## Questions

Please fill out answers to these questions, it'll help us figure out
why things are going wrong.

- **What did you do?**

 I ran the command `/usr/bin/bundle --local --quiet`

- **What did you expect to happen?**

 I expected Bundler to...

- **What happened instead?**

 Instead, what happened was...

- **Have you tried any solutions posted on similar issues in our issue tracker, stack overflow, or google?**

 I tried...

- **Have you read our issues document, https://github.com/bundler/bundler/blob/master/doc/contributing/ISSUES.md?**

 ...

## Backtrace

```
NoMethodError: undefined method `message_with_trees' for #<Molinillo::VersionConflict:0x0000559d95ce0698> /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/resolver.rb:303:in `version_conflict_message' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/resolver.rb:55:in `rescue in start' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/resolver.rb:45:in `start' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/resolver.rb:22:in `resolve' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/definition.rb:258:in `resolve' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/definition.rb:170:in `specs' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/definition.rb:151:in `resolve_with_cache!' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/installer.rb:310:in `resolve_if_needed' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/installer.rb:84:in `block in run' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/process_lock.rb:12:in `block in lock' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/process_lock.rb:9:in `open' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/process_lock.rb:9:in `lock' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/installer.rb:73:in `run' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/installer.rb:25:in `install' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/cli/install.rb:65:in `run' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/cli.rb:235:in `block in install' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/settings.rb:143:in `temporary' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/cli.rb:234:in `install'
 /usr/lib/ruby/vendor_ruby/thor/command.rb:27:in `run'
 /usr/lib/ruby/vendor_ruby/thor/invocation.rb:126:in `invoke_command'
 /usr/lib/ruby/vendor_ruby/thor.rb:369:in `dispatch'
/usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/cli.rb:27:in `dispatch'
 /usr/lib/ruby/vendor_ruby/thor/base.rb:444:in `start'
/usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/cli.rb:18:in `start' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/exe/bundle:30:in `block in <top (required)>' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/lib/bundler/friendly_errors.rb:124:in `with_friendly_errors' /usr/share/rubygems-integration/all/gems/bundler-1.17.3/exe/bundle:22:in `<top (required)>'
 /usr/bin/bundle:23:in `load'
 /usr/bin/bundle:23:in `<main>'
```

## Environment

```
Bundler 1.17.3
 Platforms ruby, x86_64-linux
Ruby 2.5.5p157 (2019-03-15 revision 67260) [x86_64-linux-gnu]
 Full Path /usr/bin/ruby2.5
 Config Dir /etc
RubyGems 2.7.6.2
 Gem Home /var/lib/gitlab/.gem
Gem Path /var/lib/gitlab/.gem/ruby/2.5.0:/var/lib/gems/2.5.0:/usr/lib/x86_64-linux-gnu/rubygems-integration/2.5.0:/usr/share/rubygems-integration/2.5.0:/usr/share/rubygems-integration/all:/var/lib/gitlab/.gem
 User Path /var/lib/gitlab/.gem/ruby/2.5.0
 Bin Dir /var/lib/gitlab/.gem/bin
OpenSSL
 Compiled OpenSSL 1.1.1c 28 May 2019
 Loaded OpenSSL 1.1.1d 10 Sep 2019
 Cert File /usr/lib/ssl/cert.pem
 Cert Dir /usr/lib/ssl/certs
Tools
 Git 2.20.1
 RVM not installed
 rbenv not installed
 chruby not installed
Gem.ruby /usr/bin/ruby2.5
bundle #! /usr/bin/ruby

```

## Bundler Build Metadata

```
Built At 2018-12-27
Git SHA d7089abb6
Released Version true
```

## Bundler settings

```
without
Set for your local app (/usr/share/gitlab/.bundle/config): [:development, :test] Set for the current user (/var/lib/gitlab/.bundle/config): [:development, :test]
```

_______________________________________________
Pkg-ruby-extras-maintainers mailing list
Pkg-ruby-extras-maintainers@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-ruby-extras-maintainers

Reply via email to