package: chef,chef-zero
version: 12.10.24-1
severity: serious

Update of chef-zero without testing reverse dependency compatibility
caused the issue.

adt-run [18:55:42]: test command1: gem2deb-test-runner
--check-dependencies --autopkgtest
adt-run [18:55:42]: test command1: [-----------------------

┌──────────────────────────────────────────────────────────────────────────────┐
│ Checking Rubygems dependency resolution on ruby2.3
      │
└──────────────────────────────────────────────────────────────────────────────┘

GEM_PATH= ruby2.3 -e gem\ \"chef\"
/usr/lib/ruby/2.3.0/rubygems/dependency.rb:319:in `to_specs': Could not
find 'chef-zero' (~> 4.5) - did find: [chef-zero-5.0.0] (Gem::LoadError)
Checked in
'GEM_PATH=/home/debci/.gem/ruby/2.3.0:/var/lib/gems/2.3.0:/usr/lib/x86_64-linux-gnu/rubygems-integration/2.3.0:/usr/share/rubygems-integration/2.3.0:/usr/share/rubygems-integration/all',
execute `gem env` for more information
        from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1438:in `block in
activate_dependencies'
        from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1427:in `each'
        from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1427:in
`activate_dependencies'
        from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1409:in `activate'
        from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:68:in `block
in gem'
        from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:67:in
`synchronize'
        from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:67:in `gem'
        from -e:1:in `<main>'

Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Pkg-ruby-extras-maintainers mailing list
Pkg-ruby-extras-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-ruby-extras-maintainers

Reply via email to