Your message dated Sun, 06 Aug 2017 15:38:20 +0000
with message-id <e1dende-000cpe...@fasolo.debian.org>
and subject line Bug#869175: fixed in ruby-specinfra 2.70.0-1
has caused the Debian Bug report #869175,
regarding ruby-specinfra: FTBFS: can't satisfy 'net-ssh (< 4.0, >= 2.7)', 
already activated 'net-ssh-4.1.0' (Gem::LoadError)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
869175: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=869175
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: ruby-specinfra
Version: 2.66.0-1
Severity: serious
Tags: buster sid
User: debian...@lists.debian.org
Usertags: qa-ftbfs-20170721 qa-ftbfs
Justification: FTBFS on amd64

Hi,

During a rebuild of all packages in sid, your package failed to build on
amd64.

Relevant part (hopefully):
> Invalid gemspec in [specinfra.gemspec]: No such file or directory - git
> GEM_PATH=debian/ruby-specinfra/usr/share/rubygems-integration/all:/var/lib/gems/2.3.0:/usr/lib/x86_64-linux-gnu/rubygems-integration/2.3.0:/usr/share/rubygems-integration/2.3.0:/usr/share/rubygems-integration/all
>  ruby2.3 -e gem\ \"specinfra\"
> /usr/lib/ruby/2.3.0/rubygems/specification.rb:1436:in `block in 
> activate_dependencies': can't satisfy 'net-ssh (< 4.0, >= 2.7)', already 
> activated 'net-ssh-4.1.0' (Gem::LoadError)
>       from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1428:in `each'
>       from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1428:in 
> `activate_dependencies'
>       from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1410:in `activate'
>       from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:68:in `block 
> in gem'
>       from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:67:in 
> `synchronize'
>       from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:67:in `gem'
>       from -e:1:in `<main>'
> bcrypt_pbkdf (1.0.0)
> bigdecimal (1.2.8)
> bundler (1.15.1)
> did_you_mean (1.0.0)
> diff-lcs (1.3)
> ffi (1.9.10)
> io-console (0.4.5)
> json (1.8.3)
> minitest (5.10.2)
> molinillo (0.5.0)
> net-http-persistent (2.9.4)
> net-scp (1.2.1)
> net-ssh (4.1.0)
> net-telnet (0.1.1)
> power_assert (0.2.7)
> psych (2.1.0)
> rake (12.0.0)
> rbnacl (5.0.0)
> rdoc (4.2.1)
> rspec (3.5.0)
> rspec-core (3.5.3)
> rspec-expectations (3.5.0)
> rspec-its (1.2.0)
> rspec-mocks (3.5.0)
> rspec-support (3.5.0)
> test-unit (3.2.5)
> thor (0.19.4)
> thread_order (1.1.0)
> ERROR: Test "ruby2.3" failed: 

The full build log is available from:
   http://aws-logs.debian.net/2017/07/21/ruby-specinfra_2.66.0-1_unstable.log

A list of current common problems and possible solutions is available at
http://wiki.debian.org/qa.debian.org/FTBFS . You're welcome to contribute!

About the archive rebuild: The rebuild was done on EC2 VM instances from
Amazon Web Services, using a clean, minimal and up-to-date chroot. Every
failed build was retried once to eliminate random failures.

--- End Message ---
--- Begin Message ---
Source: ruby-specinfra
Source-Version: 2.70.0-1

We believe that the bug you reported is fixed in the latest version of
ruby-specinfra, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 869...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
HIGUCHI Daisuke (VDR dai) <d...@debian.org> (supplier of updated ruby-specinfra 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Mon, 07 Aug 2017 00:10:36 +0900
Source: ruby-specinfra
Binary: ruby-specinfra
Architecture: source all
Version: 2.70.0-1
Distribution: unstable
Urgency: medium
Maintainer: Debian Ruby Extras Maintainers 
<pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Changed-By: HIGUCHI Daisuke (VDR dai) <d...@debian.org>
Description:
 ruby-specinfra - Common layer for serverspec and configspec
Closes: 869175
Changes:
 ruby-specinfra (2.70.0-1) unstable; urgency=medium
 .
   * Team upload.
 .
   [ HIGUCHI Daisuke (VDR dai) ]
   * Add d/tests/control.
 .
   [ Unit 193 ]
   * New upstream version 2.70.0
     - Add support for net-ssh 4.0 (Closes: #869175)
     - Refresh patch.
   * Update Standards-Version to 4.0.0.
   * d/control, d/copyright: Update some URLs to 'https'.
   * d/control: Add (Build-)Depend on ruby-net-telnet.
   * d/control: Depend on net-tools.
Checksums-Sha1:
 c2fc6d080b95f682f86378e2b02383ee4f610b68 2358 ruby-specinfra_2.70.0-1.dsc
 26b0fa311154322d540e5415a844815c475b750a 83332 
ruby-specinfra_2.70.0.orig.tar.gz
 6671b0ea8230d08a8e5278b34a2b9a4c04f79c0c 3240 
ruby-specinfra_2.70.0-1.debian.tar.xz
 1e549753bd3dd24b9cc3d80eb05ba0ac95e8dc20 56676 ruby-specinfra_2.70.0-1_all.deb
 50539aeb19611cf9d48a6a750221f275abad0f47 7673 
ruby-specinfra_2.70.0-1_amd64.buildinfo
Checksums-Sha256:
 38f64248e9be3a8453e9f6462b8db54d7e484b242cb117c689906b9485b1a798 2358 
ruby-specinfra_2.70.0-1.dsc
 71369edde736aa5dee0d0eb46606aa3e9d11c0439c3d07c3957b8a16047e6480 83332 
ruby-specinfra_2.70.0.orig.tar.gz
 d042526b471e82227c4b867e218ea7c64cccad6102867508a7af3dc98495d2e8 3240 
ruby-specinfra_2.70.0-1.debian.tar.xz
 a6e006ebe5d8e031292bbd6fef132933d45bdd29530f50a905838ab649b9a8f5 56676 
ruby-specinfra_2.70.0-1_all.deb
 a6333ea35804de217cfbdae7446f075d20f9109a1d318ff7e4ec541e9b44a660 7673 
ruby-specinfra_2.70.0-1_amd64.buildinfo
Files:
 45442b249d771530f3f55e2bbc2c6a56 2358 ruby optional ruby-specinfra_2.70.0-1.dsc
 d9c2135ae5465c62a7c851934aa1d689 83332 ruby optional 
ruby-specinfra_2.70.0.orig.tar.gz
 37e0fff64cd7265a3769767d7a995d7c 3240 ruby optional 
ruby-specinfra_2.70.0-1.debian.tar.xz
 1c0cf4a5b0d816ab3f2557d73dd568a4 56676 ruby optional 
ruby-specinfra_2.70.0-1_all.deb
 0b04d11ded9e1af77c19036788b791ff 7673 ruby optional 
ruby-specinfra_2.70.0-1_amd64.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEECynYjkLmt2W42OpQeDlhndQ5Zo4FAlmHMvAACgkQeDlhndQ5
Zo4uzw/+PgBmQufI5v3qYuXSz7UBBunEU8VgXtxW6/pMFI1bvF2gxUHySN17Sxyu
ASbNY2IwbLTD+knx3coFCPsAQeZ1rtOCw4z6UvTJtj/umcDF1ICmToNAIRvkhg6n
i1K8ZkPv4p6UJEDJAZo/16PLTRZesQinFCX+vQAN4CtGAuFXzb1FrVzSt1p07xUe
gN8tltsHUFdb7XaQjrXqxlP9w8gIE2sdzfY1HpdkSnDr/ZqDzEAmXSniHpOOb5++
enStOwfbYw3zQDMtCiCVzUQKWEpW94a9y7aqA140ZwAy0z4spaK9GpbzgmR5b/NZ
pj3rszLwWq8qftZqxCPWYrMHWV4eXWG2P2kmUm3imUxWEFVQj2rSKn+NltbjGqgq
nt5BeQLPdN7t8W9W0xJpy0P1mnBgLOxNtV0KCSNc58/jgu6lxXIVXPSz3vWLVO3a
SLjuEF4Kku42RGDACv8Bf9r6Dyyt8QPHRuC1z68S33fhbTDvQsjt5M0wlclDKO/j
xp9Y6flXGL/3nq+ZB4ze4I+ljaLNOhkSqmWWz0/O8RPMumEp4K2+CekNY9FoRVGf
0TMyF0xrVomSslcOVZqNKchKxyuXucBZxdToi/eQzjvegniW7xMW9bKzcktFkiAL
451dsUTamhJgyYLF+HkFffWqP0/sz4+kEg0wPf3oGdDXENDCdiQ=
=Nr0/
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-ruby-extras-maintainers mailing list
Pkg-ruby-extras-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-ruby-extras-maintainers

Reply via email to