Package: vagrant
Version: 1.9.1+dfsg-1
Severity: grave
Justification: renders package unusable

Hi,

It seems that Hashicorp decided to migrate from e.g.
https://atlas.hashicorp.com/alpine/alpine64
to
https://app.vagrantup.com/alpine/boxes/alpine64

This breaks images download, making this package essentially
unfortunately:

$ vagrant init alpine/alpine64
A `Vagrantfile` has been placed in this directory. You are now
ready to `vagrant up` your first virtual environment! Please read
the comments in the Vagrantfile as well as documentation on
`vagrantup.com` for more information on using Vagrant.

$ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Box 'alpine/alpine64' could not be found. Attempting to find and 
install...
    default: Box Provider: virtualbox
    default: Box Version: >= 0
The box 'alpine/alpine64' could not be found or
could not be accessed in the remote catalog. If this is a private
box on HashiCorp's Atlas, please verify you're logged in via
`vagrant login`. Also, please double-check the name. The expanded
URL and error message are shown below:

URL: ["https://atlas.hashicorp.com/alpine/alpine64";]
Error: The requested URL returned error: 404 Not Found

- Lucas


-- System Information:
Debian Release: 9.3
  APT prefers stable
  APT policy: (990, 'stable'), (500, 'stable-updates'), (400, 'testing'), (300, 
'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.9.0-5-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages vagrant depends on:
ii  bsdtar             3.2.2-2
ii  curl               7.52.1-5+deb9u3
ii  openssh-client     1:7.4p1-10+deb9u2
ii  ruby               1:2.3.3
ii  ruby-bundler       1.15.1-1
ii  ruby-childprocess  0.5.9-1
ii  ruby-erubis        2.7.0-3
ii  ruby-i18n          0.7.0-2
ii  ruby-listen        3.0.3-3
ii  ruby-log4r         1.1.10-4
ii  ruby-net-scp       1.2.1-4
ii  ruby-net-sftp      1:2.1.2-3
ii  ruby-net-ssh       1:4.2.0-2
ii  ruby-nokogiri      1.6.8.1-1
ii  ruby-rb-inotify    0.9.7-1
ii  ruby-rest-client   1.8.0-3

vagrant recommends no packages.

Versions of packages vagrant suggests:
ii  virtualbox  5.1.30-dfsg-1~bpo9+1

-- no debconf information

_______________________________________________
Pkg-ruby-extras-maintainers mailing list
Pkg-ruby-extras-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-ruby-extras-maintainers

Reply via email to