Source: foodcritic
Version: 8.1.0-1
Severity: serious
Tags: buster sid

https://ci.debian.net/packages/f/foodcritic/unstable/amd64/
https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/foodcritic.html

...
┌──────────────────────────────────────────────────────────────────────────────┐
│ Run tests for ruby2.5 from debian/ruby-tests.rake                            │
└──────────────────────────────────────────────────────────────────────────────┘

RUBYLIB=/build/1st/foodcritic-8.1.0/debian/foodcritic/usr/lib/ruby/vendor_ruby:.
 
GEM_PATH=debian/foodcritic/usr/share/rubygems-integration/all:/var/lib/gems/2.5.0:/usr/lib/x86_64-linux-gnu/rubygems-integration/2.5.0:/usr/share/rubygems-integration/2.5.0:/usr/share/rubygems-integration/all
 ruby2.5 -S rake -f debian/ruby-tests.rake
warning: simplecov gem not found; skipping coverage
/usr/lib/ruby/vendor_ruby/treetop/compiler/metagrammar.rb:1104: warning: 
mismatched indentations at 'end' with 'def' at 1102
/usr/lib/ruby/vendor_ruby/treetop/compiler/metagrammar.rb:1221: warning: 
mismatched indentations at 'end' with 'def' at 1219
/usr/lib/ruby/vendor_ruby/treetop/compiler/metagrammar.rb:1468: warning: 
mismatched indentations at 'end' with 'def' at 1466
/usr/lib/ruby/vendor_ruby/treetop/compiler/metagrammar.rb:1500: warning: 
mismatched indentations at 'end' with 'def' at 1498
/usr/lib/ruby/vendor_ruby/treetop/compiler/metagrammar.rb:1543: warning: 
mismatched indentations at 'end' with 'def' at 1541
/usr/lib/ruby/vendor_ruby/treetop/compiler/metagrammar.rb:1582: warning: 
mismatched indentations at 'end' with 'def' at 1580
/usr/lib/ruby/vendor_ruby/treetop/compiler/grammar_compiler.rb:37: warning: 
shadowing outer local variable - ext
/build/1st/foodcritic-8.1.0/lib/foodcritic/chef.rb:55: warning: shadowing outer 
local variable - version
/build/1st/foodcritic-8.1.0/lib/foodcritic/linter.rb:286: warning: shadowing 
outer local variable - m
/build/1st/foodcritic-8.1.0/lib/foodcritic/template.rb:41: warning: shadowing 
outer local variable - e
/usr/bin/ruby2.5 -I "lib" "/usr/bin/cucumber" -f progress --strict -t ~@build 
-t ~@context features
warning: simplecov gem not found; skipping coverage
.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................F..F..F..F.....F...............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

(::) failed steps (::)

Expected "FC011: Missing README in markdown format: 
cookbooks/example/README.md:1\nFC031: Cookbook without metadata file: 
cookbooks/example/metadata.rb:1\nFC045: Metadata does not contain cookbook 
name: cookbooks/example/metadata.rb:1\n" to include "FC025: Prefer chef_gem to 
compile-time gem install: cookbooks/example/recipes/default.rb:". 
(Minitest::Assertion)
./features/support/command_helpers.rb:252:in `expect_output'
./features/support/command_helpers.rb:136:in `expect_warning'
./features/step_definitions/cookbook_steps.rb:2251:in `/^the\ prefer\ chef_gem\ 
to\ manual\ install\ warning\ 025\ should\ be\ shown$/'
features/025_check_for_deprecated_gem_install.feature:15:in `Then the prefer 
chef_gem to manual install warning 025 should be shown'

Expected "FC011: Missing README in markdown format: 
cookbooks/example/README.md:1\nFC031: Cookbook without metadata file: 
cookbooks/example/metadata.rb:1\nFC045: Metadata does not contain cookbook 
name: cookbooks/example/metadata.rb:1\n" to include "FC025: Prefer chef_gem to 
compile-time gem install: cookbooks/example/recipes/default.rb:". 
(Minitest::Assertion)
./features/support/command_helpers.rb:252:in `expect_output'
./features/support/command_helpers.rb:136:in `expect_warning'
./features/step_definitions/cookbook_steps.rb:2251:in `/^the\ prefer\ chef_gem\ 
to\ manual\ install\ warning\ 025\ should\ be\ shown$/'
features/025_check_for_deprecated_gem_install.feature:20:in `Then the prefer 
chef_gem to manual install warning 025 should be shown'

Expected "FC011: Missing README in markdown format: 
cookbooks/example/README.md:1\nFC031: Cookbook without metadata file: 
cookbooks/example/metadata.rb:1\nFC045: Metadata does not contain cookbook 
name: cookbooks/example/metadata.rb:1\n" to include "FC025: Prefer chef_gem to 
compile-time gem install: cookbooks/example/recipes/default.rb:". 
(Minitest::Assertion)
./features/support/command_helpers.rb:252:in `expect_output'
./features/support/command_helpers.rb:136:in `expect_warning'
./features/step_definitions/cookbook_steps.rb:2251:in `/^the\ prefer\ chef_gem\ 
to\ manual\ install\ warning\ 025\ should\ be\ shown$/'
features/025_check_for_deprecated_gem_install.feature:25:in `Then the prefer 
chef_gem to manual install warning 025 should be shown'

Expected "FC011: Missing README in markdown format: 
cookbooks/example/README.md:1\nFC031: Cookbook without metadata file: 
cookbooks/example/metadata.rb:1\nFC045: Metadata does not contain cookbook 
name: cookbooks/example/metadata.rb:1\n" to include "FC025: Prefer chef_gem to 
compile-time gem install: cookbooks/example/recipes/default.rb:". 
(Minitest::Assertion)
./features/support/command_helpers.rb:252:in `expect_output'
./features/support/command_helpers.rb:136:in `expect_warning'
./features/step_definitions/cookbook_steps.rb:2251:in `/^the\ prefer\ chef_gem\ 
to\ manual\ install\ warning\ 025\ should\ be\ shown$/'
features/025_check_for_deprecated_gem_install.feature:30:in `Then the prefer 
chef_gem to manual install warning 025 should be shown'

Expected "FC011: Missing README in markdown format: 
cookbooks/example/README.md:1\nFC031: Cookbook without metadata file: 
cookbooks/example/metadata.rb:1\nFC033: Missing template: 
cookbooks/example/recipes/default.rb:1\nFC045: Metadata does not contain 
cookbook name: cookbooks/example/metadata.rb:1\n" to include "FC026: 
Conditional execution block attribute contains only string: 
cookbooks/example/recipes/default.rb:". (Minitest::Assertion)
./features/support/command_helpers.rb:252:in `expect_output'
./features/support/command_helpers.rb:136:in `expect_warning'
./features/step_definitions/cookbook_steps.rb:2167:in `/^the conditional block 
contains only string warning 026 should be (shown|not shown)$/'
features/026_check_for_conditional_block_string.feature:15:in `Then the 
conditional block contains only string warning 026 should be shown'
features/026_check_for_conditional_block_string.feature:10:in `Then the 
conditional block contains only string warning 026 should be <show_warning>'

Failing Scenarios:
cucumber features/025_check_for_deprecated_gem_install.feature:12 # Scenario: 
Compile-time gem install
cucumber features/025_check_for_deprecated_gem_install.feature:17 # Scenario: 
Compile-time gem upgrade
cucumber features/025_check_for_deprecated_gem_install.feature:22 # Scenario: 
Compile-time gem install - multiple from array
cucumber features/025_check_for_deprecated_gem_install.feature:27 # Scenario: 
Compile-time gem install - multiple from wordlist
cucumber features/026_check_for_conditional_block_string.feature:15 # Scenario 
Outline: , Examples (#2)

748 scenarios (5 failed, 743 passed)
2404 steps (5 failed, 2399 passed)
1m51.078s
ERROR: Test "ruby2.5" failed. Exiting.
dh_auto_install: dh_ruby --install 
/build/1st/foodcritic-8.1.0/debian/foodcritic returned exit code 1
make: *** [debian/rules:4: binary] Error 1
_______________________________________________
Pkg-ruby-extras-maintainers mailing list
Pkg-ruby-extras-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-ruby-extras-maintainers

Reply via email to