Your message dated Sun, 11 Mar 2018 21:06:14 +0530
with message-id <7d54b778-6d83-3f77-05ba-9e5f4b64d...@debian.org>
and subject line this is already fixed
has caused the Debian Bug report #868839,
regarding ruby-mustermann: missing Breaks+Replaces: ruby-mustermann19
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
868839: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=868839
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: ruby-mustermann,ruby-mustermann19
Severity: serious
User: trei...@debian.org
Usertags: edos-file-overwrite
Control: found -1 1.0.0-2
Control: found -1 0.4.3+git20160621-1

Hi,

automatic installation tests of packages that share a file and at the
same time do not conflict by their package dependency relationships has
detected the following problem:

  Selecting previously unselected package ruby-mustermann19.
  Preparing to unpack .../ruby-mustermann19_0.4.3+git20160621-1_all.deb ...
  Unpacking ruby-mustermann19 (0.4.3+git20160621-1) ...
  dpkg: error processing archive 
/var/cache/apt/archives/ruby-mustermann19_0.4.3+git20160621-1_all.deb 
(--unpack):
   trying to overwrite 
'/usr/lib/ruby/vendor_ruby/mustermann/ast/boundaries.rb', which is also in 
package ruby-mustermann 1.0.0-2
  Errors were encountered while processing:
   /var/cache/apt/archives/ruby-mustermann19_0.4.3+git20160621-1_all.deb

This is a serious bug as it makes installation fail, and violates
sections 7.6.1 and 10.1 of the policy. An optimal solution would
consist in only one of the packages installing that file, and renaming
or removing the file in the other package. Depending on the
circumstances you might also consider Replace relations or file
diversions. If the conflicting situation cannot be resolved then, as a
last resort, the two packages have to declare a mutual
Conflict. Please take into account that Replaces, Conflicts and
diversions should only be used when packages provide different
implementations for the same functionality.

Here is a list of files that are known to be shared by both packages
(according to the Contents file for sid/amd64, which may be
slightly out of sync):

usr/lib/ruby/vendor_ruby/mustermann.rb
usr/lib/ruby/vendor_ruby/mustermann/ast/boundaries.rb
usr/lib/ruby/vendor_ruby/mustermann/ast/compiler.rb
usr/lib/ruby/vendor_ruby/mustermann/ast/expander.rb
usr/lib/ruby/vendor_ruby/mustermann/ast/node.rb
usr/lib/ruby/vendor_ruby/mustermann/ast/param_scanner.rb
usr/lib/ruby/vendor_ruby/mustermann/ast/parser.rb
usr/lib/ruby/vendor_ruby/mustermann/ast/pattern.rb
usr/lib/ruby/vendor_ruby/mustermann/ast/template_generator.rb
usr/lib/ruby/vendor_ruby/mustermann/ast/transformer.rb
usr/lib/ruby/vendor_ruby/mustermann/ast/translator.rb
usr/lib/ruby/vendor_ruby/mustermann/ast/validation.rb
usr/lib/ruby/vendor_ruby/mustermann/caster.rb
usr/lib/ruby/vendor_ruby/mustermann/composite.rb
usr/lib/ruby/vendor_ruby/mustermann/equality_map.rb
usr/lib/ruby/vendor_ruby/mustermann/error.rb
usr/lib/ruby/vendor_ruby/mustermann/expander.rb
usr/lib/ruby/vendor_ruby/mustermann/extension.rb
usr/lib/ruby/vendor_ruby/mustermann/identity.rb
usr/lib/ruby/vendor_ruby/mustermann/mapper.rb
usr/lib/ruby/vendor_ruby/mustermann/pattern.rb
usr/lib/ruby/vendor_ruby/mustermann/pattern_cache.rb
usr/lib/ruby/vendor_ruby/mustermann/regexp.rb
usr/lib/ruby/vendor_ruby/mustermann/regexp_based.rb
usr/lib/ruby/vendor_ruby/mustermann/regular.rb
usr/lib/ruby/vendor_ruby/mustermann/simple_match.rb
usr/lib/ruby/vendor_ruby/mustermann/sinatra.rb
usr/lib/ruby/vendor_ruby/mustermann/to_pattern.rb
usr/lib/ruby/vendor_ruby/mustermann/version.rb


This bug is assigned to both packages. If you, the maintainers of
the two packages in question, have agreed on which of the packages will
resolve the problem please reassign the bug to that package. You may
also register in the BTS that the other package is affected by the bug.

Cheers,

Andreas

PS: for more information about the detection of file overwrite errors
of this kind see https://qa.debian.org/dose/file-overwrites.html

Attachment: ruby-mustermann=1.0.0-2_ruby-mustermann19=0.4.3+git20160621-1.log.gz
Description: application/gzip


--- End Message ---
--- Begin Message ---
Control: fixed -1 1.0.0-3

See
https://tracker.debian.org/media/packages/r/ruby-mustermann/control-1.0.0-3

Attachment: signature.asc
Description: OpenPGP digital signature


--- End Message ---
_______________________________________________
Pkg-ruby-extras-maintainers mailing list
Pkg-ruby-extras-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-ruby-extras-maintainers

Reply via email to