control: severity -1 serious

On 2018-03-05 23:09, Sven Joachim wrote:
> Package: gem2deb
> Version: 0.38
> Severity: important
> 
> In the last binNMU of redland-bindings, both librdf-perl and
> python-librdf gained a dependency on ruby (<< 1:2.6~).  This cannot be
> right, since these packages have nothing to do with ruby whatsoever.

As we have some essential packages like libselinux that have a ruby
binding, and upload of any of them would make ruby de facto essential.
I am therefore raising the severity.

> Most likely the fix for #889470 is responsible for this, but I know
> nothing about ruby.

Indeed I confirm that:

--- a/bin/dh_ruby_fixdepends
+++ b/bin/dh_ruby_fixdepends
@@ -40,7 +40,8 @@ include Gem2Deb
           std_deps << dep
         end
       end
-      newdeps = (std_deps + [libruby_deps.join(' | ')] + [ruby_deps.join(' | 
')]).join(', ')
+      upper_bound = RubyDebianDev.ruby_upper_bound
+      newdeps = (std_deps + [libruby_deps.join(' | ')] + [ruby_deps.join(' | 
')] + [upper_bound]).join(', ')
       fd.puts "shlibs:Depends=#{newdeps}"
     else
       fd.puts l

The upper_bound should only be added if libruby_deps or ruby_deps are not empty.

-- 
Aurelien Jarno                          GPG: 4096R/1DDD8C9B
aurel...@aurel32.net                 http://www.aurel32.net

_______________________________________________
Pkg-ruby-extras-maintainers mailing list
Pkg-ruby-extras-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-ruby-extras-maintainers

Reply via email to