Package: systemd-container
Version: 232-25+deb9u3
Severity: minor
File: /usr/bin/systemd-nspawn

Dear Maintainer,

I wanted to set an environment variable inside the container, when
running a command with systemd-nspawn. -E doesn't work, --setenv does.

First, to show that the container works:

    $ sudo systemd-nspawn -D tmp env
    Spawning container tmp on /scratch/liw/systrees/tmp.
    Press ^] three times within 1s to kill container.
    PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    container=systemd-nspawn
    TERM=xterm-256color
    HOME=/root
    USER=root
    LOGNAME=root
    container_uuid=2f016265-dfad-46e0-944e-7708b7f44bef
    NOTIFY_SOCKET=/run/systemd/nspawn/notify
    Container tmp exited successfully.

Second, set environment variable with -E: it doesn't work.

    $ sudo systemd-nspawn -D tmp -E FOO=bar env
    systemd-nspawn: invalid option -- 'E'

Third, do it with --setenv, and it works:

    $ sudo systemd-nspawn -D tmp --setenv FOO=bar env
    Spawning container tmp on /scratch/liw/systrees/tmp.
    Press ^] three times within 1s to kill container.
    PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    container=systemd-nspawn
    TERM=xterm-256color
    HOME=/root
    USER=root
    LOGNAME=root
    container_uuid=2f016265-dfad-46e0-944e-7708b7f44bef
    NOTIFY_SOCKET=/run/systemd/nspawn/notify
    FOO=bar
    Container tmp exited successfully.

I'd be OK with removing -E from the docs, or to make it work. I can
live with writing the option as --setenv.

-- System Information:
Debian Release: 9.4
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'unstable'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-6-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages systemd-container depends on:
ii  dbus             1.10.26-0+deb9u1
ii  libacl1          2.2.52-3+b1
ii  libblkid1        2.29.2-1+deb9u1
ii  libbz2-1.0       1.0.6-8.1
ii  libc6            2.24-11+deb9u3
ii  libcurl3-gnutls  7.52.1-5+deb9u5
ii  libgcrypt20      1.7.6-2+deb9u2
ii  libip4tc0        1.6.0+snapshot20161117-6
ii  liblzma5         5.2.2-1.2+b1
ii  libseccomp2      2.3.1-2.1
ii  libselinux1      2.6-3+b3
ii  systemd          232-25+deb9u3
ii  zlib1g           1:1.2.8.dfsg-5

Versions of packages systemd-container recommends:
ii  btrfs-progs        4.7.3-1
ii  btrfs-tools        4.7.3-1
ii  libnss-mymachines  232-25+deb9u3

systemd-container suggests no packages.

-- no debconf information

_______________________________________________
Pkg-systemd-maintainers mailing list
Pkg-systemd-maintainers@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/pkg-systemd-maintainers

Reply via email to