Hi Aurelien,

On Mon, Feb 12, 2018 at 2:55 PM, Aurelien Jarno <aure...@debian.org> wrote:
>
> Starting with glibc 2.27, support for the "ieee" library (part of SVID
> specification) has been removed. The libieee.a library is therefore not
> shipped anymore.
>
> tcl8.6 already works without this library however the configure script
> detects it and enable support for it if available. The side effects are
> that the "-lieee" link option is then shipped in tclConfig.sh, and that
> the library ends up with the _LIB_VERSION symbol.
>
> To avoid ease the glibc 2.27, I believe it's better to separate the two.
> I have therefore attached a patch to always disable libieee support in
> tcl8.6. The patch can be removed once glibc 2.27 is in testing (but can
> also be kept safely). It will require tk8.6 to be rebuilt against the
> new tcl8.6 as it also exports the "-lieee" link option through
> tkConfig.sh and also removes the _LIB_VERSION symbol. A patch is also
> attached for that.
>
> Do you feel it is an acceptable way to proceed. Another alternative
> would be to just declare the _LIB_VERSION symbol as optional in both
> tcl8.6 and tk8.6, and handle the change through binNMUs as part of the
> glibc 2.27 transition. Please feel free to suggest other options.

It's okay to me to apply this patch and dropped linking to libieee preemptively.
Tcl tests seem to be okay without libieee, so I'll upload the patched package
shortly along with tcl/tk 8.5 and 8.7 (in experimental).

Cheers!
-- 
Sergei Golovan

_______________________________________________
Pkg-tcltk-devel mailing list
Pkg-tcltk-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-tcltk-devel

Reply via email to