Control: tags -1 + confirmed moreinfo

On Sat, 17 Feb 2018 at 23:57:48 +0100, Aurelien Jarno wrote:
> flatpak 0.10.3-1 (and version 0.10.4-1 currently in sid) fails to build
> with glibc 2.27 (2.27-0experimental0 from experimental)

Did you test 0.10.4-1 unsuccessfully, or is that based on extrapolation
from 0.10.3-1? I can confirm that 0.10.3-1 FTBFS in the way you described,
but 0.10.4-1 builds OK for me with glibc 2.27-0experimental0.

> glibc 2.27 added support for copy_file_range. Unfortunately flatpak,
> or rather the included libglnx library, also has such a function to
> wrap the corresponding syscall.
> 
> The issue has already been fixed upstream in commit 3e16d4ef with an
> update of the libglnx submodule. The corresponding libglnx commit is
> 4577dc82.

flatpak 0.11.0 has the upstream fix that you described, so this is
certainly fixed in experimental.

flatpak 0.10.4 has commit 084164a20ad2ea5a02ed7e9a915cb3539a8828ba
which is meant to fix copy_file_range detection with the older libglnx
submodule: <https://github.com/flatpak/flatpak/pull/1401>. So I believe
this should also be fixed in unstable already?

Thanks,
    smcv

_______________________________________________
Pkg-utopia-maintainers mailing list
Pkg-utopia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-utopia-maintainers

Reply via email to