On 2018-02-19 09:43, Simon McVittie wrote:
> Control: forwarded -1 https://github.com/GNOME/libglnx/pull/103
> Control: tags -1 + fixed-upstream pending
> 
> On Sat, 17 Feb 2018 at 23:57:53 +0100, Aurelien Jarno wrote:
> > flatpack-builder 0.10.8-1 fails to build with glibc 2.27
> > (2.27-0experimental0 from experimental):
> > | ./libglnx/glnx-missing-syscall.h:105:19: error: static declaration of 
> > 'memfd_create' follows non-static declaration
> > 
> > glibc 2.27 added support for memfd_create. Unfortunately
> > flatpak-builder, or rather the included libglnx library, also has such a
> > function to wrap the corresponding syscall. It correctly tries to detect
> > it in the configure script to disabled the wrapper in case glibc
> > provides it. However it doesn't work due to a missing include. The
> > attached patch fixes that.
> 
> Thanks, I've sent this upstream to libglnx (where it was accepted)
> and applied it in Debian. Upstream is in the process of releasing
> flatpak-builder 0.10.9 anyway, with the updated libglnx included, so
> I'll probably wait for that version instead of uploading with your patch.

Thanks a lot for fixing the bug upstream. There is no urgency, I don't
expect to upload glibc 2.27 to unstable before at least one week.

Aurelien

-- 
Aurelien Jarno                          GPG: 4096R/1DDD8C9B
aurel...@aurel32.net                 http://www.aurel32.net

_______________________________________________
Pkg-utopia-maintainers mailing list
Pkg-utopia-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-utopia-maintainers

Reply via email to