On Thursday 11 September 2008 20:17:08 Aaron J. Seigo wrote: > personally, to keep the proper semantics in place for UI, config, etc, i'd > do something like: > > // copy the main applet structure > (*this) = Applet::packageStructure(); > > // now add our own stuff > addFileDefinition("webpage", "html/index.html", i18n("Main Html"));
Yes, that's much better. > *that* said ... what's wrong with simply having code/main the same as > html/index.html, and stuffing the rest of the html files into code/? Nothing wrong. Still learning PackageStructure. I'll use that. > -K_EXPORT_PLASMA_APPLETSCRIPTENGINE(webapplet, WebApplet) > +K_EXPORT_PLASMA_APPLETSCRIPTENGINE(webkit, PlasmaWebApplet) > > if we're going to do this, then we really all the Plasma specific methods > should be moved to PlasmaWebApplet, e.g. dataUpdated, dataFor, > configAccepted.. Yes, that's true. > why are you managing the engines yourself instead of letting the Applet* > you are given do that for you? that's a lot of duplicated code that's > unecessary. Well I try to handle DataEngineWrappers but not DataEngines. Hmm, maybe DataEngineWrapper could be a child of DataEngine so it would be deleted at the same time and could be found there if needed. > > - Background does not work currently. > > ... define? I use applet()->setBackgroundHints(Plasma::Applet::DefaultBackground); in init but still get only white web page. > > - more applet functions (setBackgroundHints, resize, etc.) > > into the JS API you mean? Yes. > > - Is it ok that dashboard widgets get all the plasma functionality too? > > Or should this be a separate scriptengine. > > which plasma functionality, exactly? Currently dashboard widgets have access to e.g. dataEngines if someone wants to modify dashboard applet to do so. Petri
signature.asc
Description: This is a digitally signed message part.
_______________________________________________ Plasma-devel mailing list Plasma-devel@kde.org https://mail.kde.org/mailman/listinfo/plasma-devel