zzag added inline comments.

INLINE COMMENTS

> kcm.cpp:55
>  {
> +#if QT_VERSION < 0x050140
>      qmlRegisterType<QStandardItemModel>();

You could use `QT_VERSION_CHECK` to make the code more readable, e.g.

  #if QT_VERSION < QT_VERSION_CHECK(5, 14, 0)
      qmlRegisterType<QStandardItemModel>();
      qmlRegisterType<KCMPlymouth>();
  #else
      qmlRegisterAnonymousType<QStandardItemModel>("KCMPlymouth", 1);
      qmlRegisterAnonymousType<KCMPlymouth>("KCMPlymouth", 1);
  #endif

REPOSITORY
  R124 System Settings

REVISION DETAIL
  https://phabricator.kde.org/D25624

To: plevine, jriddell, #plasma, davidedmundson
Cc: zzag, davidedmundson, asturmlechner, plasma-devel, LeGast00n, 
The-Feren-OS-Dev, jraleigh, fbampaloukas, GB_2, ragreen, ZrenBot, ngraham, 
alexeymin, himcesjf, lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, 
apol, ahiemstra, mart

Reply via email to