nicolasfella added inline comments.

INLINE COMMENTS

> appmenumodel.cpp:246
> +    }
> +    for (auto &action: m_menu->findChildren<QAction*>()) {
> +        if (action->menu() == nullptr) {

Extract the list into a variable before iterating, else this might blow up

See 
https://github.com/KDE/clazy/blob/master/docs/checks/README-temporary-iterator.md

REPOSITORY
  R120 Plasma Workspace

REVISION DETAIL
  https://phabricator.kde.org/D29466

To: cblack, #plasma, #vdg
Cc: nicolasfella, gikari, plasma-devel, Orage, LeGast00n, The-Feren-OS-Dev, 
cblack, jraleigh, zachus, fbampaloukas, ragreen, ZrenBot, ngraham, himcesjf, 
lesliezhai, ali-mohamed, jensreuterberg, abetts, sebas, apol, ahiemstra, mart

Reply via email to