hein added inline comments.

INLINE COMMENTS

> package.cpp:362
>      foreach (const QString &contentsPrefix, d->contentsPrefixPaths) {
> -        const QString prefix = fileType == "metadata" ? d->path : (d->path + 
> contentsPrefix);
> +        const QString prefix = !d->tempRoot.isEmpty() ? (fileType == 
> "metadata" ? d->tempRoot : (d->tempRoot + contentsPrefix)) : (fileType == 
> "metadata" ? d->path : (d->path + contentsPrefix));
>  

Could you rewrite this for readability a bit? Nested ternary operators just to 
use a diff var name is ugly, we have implicitly shared strings :)

REPOSITORY
  R290 KPackage

REVISION DETAIL
  https://phabricator.kde.org/D4607

EMAIL PREFERENCES
  https://phabricator.kde.org/settings/panel/emailpreferences/

To: mart, #plasma, hein
Cc: plasma-devel, #frameworks, lesliezhai, ali-mohamed, jensreuterberg, abetts, 
sebas, apol

Reply via email to