commit f848f07b5776c398ade4050c9a9168a9b4dc54b5
Author: Elan Ruusamäe <g...@delfi.ee>
Date:   Thu Sep 15 12:50:04 2016 +0300

    skip "argparse" from egg dependencies
    
    the module is provided by python 2.7 package
    however the python 2.7 package does not provide the egg info
    so pkg_resources will fail to resolve dependencies

 egg-deps.patch         | 9 +++++++++
 translate-toolkit.spec | 3 +++
 2 files changed, 12 insertions(+)
---
diff --git a/translate-toolkit.spec b/translate-toolkit.spec
index 58597b1..2d3f75d 100644
--- a/translate-toolkit.spec
+++ b/translate-toolkit.spec
@@ -14,6 +14,7 @@ Source0:      
https://github.com/translate/translate/releases/download/%{version}-rc1
 Patch0:                %{name}-stoplist.patch
 Patch1:                %{name}-langmodel_dir.patch
 Patch2:                unbash.patch
+Patch3:                egg-deps.patch
 URL:           http://toolkit.translatehouse.org/
 BuildRequires: checkbashisms
 BuildRequires: python-dateutil
@@ -28,6 +29,7 @@ BuildRequires:        python-vobject
 %endif
 Requires:      python-iniparse >= 0.3.1
 Requires:      python-lxml >= 2.1.0
+Requires:      python-modules >= 1:2.7
 Requires:      python-setuptools
 Requires:      python-simplejson
 Requires:      python-vobject >= 0.6.6
@@ -80,6 +82,7 @@ Documentation for translate-toolkit.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 # FIXME: they do it wrong apparently? that can't do via setup.py?
 %{__sed} -i -e 's#packagesdir = get_python_lib()#packagesdir = 
"%{py_sitescriptdir}"#' setup.py
diff --git a/egg-deps.patch b/egg-deps.patch
new file mode 100644
index 0000000..747b718
--- /dev/null
+++ b/egg-deps.patch
@@ -0,0 +1,9 @@
+--- translate-toolkit-1.14.0-rc1/requirements/required.txt~    2016-03-07 
17:18:17.000000000 +0200
++++ translate-toolkit-1.14.0-rc1/requirements/required.txt     2016-09-15 
12:55:53.773712158 +0300
+@@ -1,6 +1,5 @@
+ # argparse is required for Python 2.6, it is a
+ # standard library in Python >= 2.7
+-argparse
+ six>=1.9
+ 
+ # Required to provide compatibility for old Virtaal releases:
================================================================

---- gitweb:

http://git.pld-linux.org/gitweb.cgi/packages/translate-toolkit.git/commitdiff/f848f07b5776c398ade4050c9a9168a9b4dc54b5

_______________________________________________
pld-cvs-commit mailing list
pld-cvs-commit@lists.pld-linux.org
http://lists.pld-linux.org/mailman/listinfo/pld-cvs-commit

Reply via email to