-Requires: uname(release) >= 3.13
+Requires: uname(release) >= 4.15
Is this true requirement?
I mean docs say:
README: say kernel 4.15 is the minimum recommended
After various long discussions
https://lwn.net/Articles/889610/), there is no clear answer what
version should be. Bumping the version above 3.15 doesn't allow us
to make any
significant simplifications (unless we went *much* higher). In
renameat2() is not fully supported with latest kernel versions,
e.g. nfs still
doesn't have it. And the bpf stuff is optional anyway. So let's
just say that
4.15 is what we recommend, because it provides fairly complete
without any removals of compat in the code."
"+ Kernel versions below 4.15 have significant gaps in
+ are not recommended for use with this version of systemd. Taint
+ 'old-kernel' will be set. Systemd will most likely still
+ upstream support and testing are limited."
so looks like it should work on older kernels but there could be problems.
Is there really some problem with udev-core that needs forcing >= 4.15?
(I'm still using vserver 4.9 kernels)
Arkadiusz Miśkiewicz, arekm / ( maven.pl | pld-linux.org )
pld-devel-en mailing list