udev-core change:

-Requires:      uname(release) >= 3.13
+Requires:      uname(release) >= 4.15

Is this true requirement?

I mean docs say:

    README: say kernel 4.15 is the minimum recommended

    After various long discussions

https://lwn.net/Articles/889610/), there is no clear answer what the minimum version should be. Bumping the version above 3.15 doesn't allow us to make any significant simplifications (unless we went *much* higher). In particular, even renameat2() is not fully supported with latest kernel versions, e.g. nfs still doesn't have it. And the bpf stuff is optional anyway. So let's just say that 4.15 is what we recommend, because it provides fairly complete cgroups-v2, but
    without any removals of compat in the code."


"+ Kernel versions below 4.15 have significant gaps in functionality and + are not recommended for use with this version of systemd. Taint flag + 'old-kernel' will be set. Systemd will most likely still function, but
+        upstream support and testing are limited."

so looks like it should work on older kernels but there could be problems.

Is there really some problem with udev-core that needs forcing >= 4.15? (I'm still using vserver 4.9 kernels)

Arkadiusz Miśkiewicz, arekm / ( maven.pl | pld-linux.org )
pld-devel-en mailing list

Reply via email to