UnixMan wrote: 
> Hi Philippe,
> 
> 
> Actually there are -two- different problems, with two (slightly)
> different setups. 
> 
> Let me try to explain a little better. :o
> 
> Some time ago, I did setup Riccardo's system to use "'HQPlayer Embedded'
> (https://www.signalyst.com/custom.html)" (from now on, HQPd for short)
> together with LMS.  At the time (with one of the first alpha versions of
> HQPd 4.0) the setup had to be rather convoluted, involving the use of
> LMS with your plugin, "'Rygel'
> (https://wiki.gnome.org/action/show/Projects/Rygel)" and eventually HQPd
> (all running on the same Linux box; in turn, HQPd was talking via TCP/IP
> to its "Network Audio Daemon" running on another Linux box connected to
> a UAC2 DAC, but that's irrelevant in this context).
> 
> Nevertheless, it worked pretty well for quite some time, even with
> non-local sources (Tidal, Internet "radio"s, etc). Until LMS
> automatically updated your plugin to the latest version (v0.3.0.0).
> Since then the system stopped working and I have been unable to get it
> to work again. :( 
> 
> Basically, according to the log files, HQPd receives the commands (and
> data stream reference), but it is no longer able to properly receive the
> data stream. Or maybe the problem occours between your plugin and Rygel,
> I don't know. Anyhow, the only thing which had changed when the problem
> appared was the version of your plugin.
> 
> This is about the first problem.
> 
> Next. 
> 
> Given that I was unable to fix the old setup and that now HQPlayer
> Embedded includes its own UPnP renderer interface, I have also tried to
> simplify the setup, enabling HQPd own renderer and gettin' rid of Rygel.
> 
> 
> But here comes the second problem (and the reason Riccardo posted his
> question in this topic): with such setup your plugin does recognize the
> new HQPd UPnP renderer, but squeeze2upnp crashes as soon as it creates
> the configuration for HQPd (and keep restarting and crashing
> forever...). In the logs it writes the exact same error message giving
> the title to this topic: 
> 
> “Squeeze2upnp::beat (185) crashed ... restarting”.
> 
> Can you please help? Tnx a lot. :o
> 
> 
> P.S.: of course we can do all the tests you may suggest and post the
> results here. Though you may rather prefer to run some tests yourself.
> In such a case you can easily 'download'
> (https://www.signalyst.com/embedded-install.html), install and run HQPd
> yourself (without licence it should run in demo mode, working normally
> except automatically killing itself every 30 minutes). You can either
> install a couple of (deb or rpm) packages (if you have a suitable Linux
> system), or use the bootable system image on any suitable PC.

I tried to get HQPlayerEmbedded and boot it in a VirtualBox VM - does
not seem to find a way to get that booted. Tried direct img, converted
to a vdi, wrote to a sdcard and pointed a vmdk to it - none worked



LMS 7.7, 7.8 and 7.9 - 5xRadio, 3xBoom, 4xDuet, 1xTouch, 1 SB2. Sonos
PLAY:3, PLAY:5, Marantz NR1603, JBL OnBeat, XBoxOne, XBMC, Foobar2000,
ShairPortW, JRiver 21, 2xChromecast Audio, Chromecast v1 and v2, , Pi
B3, B2, Pi B+, 2xPi A+, Odroid-C1, Odroid-C2, Cubie2, Yamaha WX-010,
AppleTV 4, Airport Express, GGMM E5
------------------------------------------------------------------------
philippe_44's Profile: http://forums.slimdevices.com/member.php?userid=17261
View this thread: http://forums.slimdevices.com/showthread.php?t=108890

_______________________________________________
plugins mailing list
plugins@lists.slimdevices.com
http://lists.slimdevices.com/mailman/listinfo/plugins

Reply via email to