Neil Griffin commented on PLUTO-781:

Hi [~riverbed2],

I tried your test portlet in Pluto 3.1.0 and found that the initial main.jsp 
view wouldn't render at all.

As I looked more closely, I noticed the following in 

    <bean id="viewResolver" 
<!--         <property name="cache" value="true" /> -->
        <property name="viewClass" 
value="org.springframework.web.servlet.view.JstlView" />
        <property name="prefix" value="/WEB-INF/jsp/" />
        <property name="suffix" value=".jsp" />

The problem is with the value of the {{viewClass}} attribute -- specifically, 
PortletMVC4Spring has it's own {{PortletJstlView}} class that helps with Pluto 
compatibility. When I tried the following, the portlet worked without any 

    <bean id="viewResolver" 
        <property name="viewClass" 
value="com.liferay.portletmvc4spring.PortletJstlView" />
        <property name="contentType" value="text/html;charset=UTF-8" />
        <property name="prefix" value="/WEB-INF/jsp/" />
        <property name="suffix" value=".jsp" />

For more info, [see the Javdoc comments in the source of 

Kind Regards,


> PortletRequestDispatcherImpl forwards to incorrect path
> -------------------------------------------------------
>                 Key: PLUTO-781
>                 URL: https://issues.apache.org/jira/browse/PLUTO-781
>             Project: Pluto
>          Issue Type: Bug
>          Components: portlet container
>    Affects Versions: 3.0.1
>         Environment: Pluto Container 3.0.1, Spring 4.0.9.RELEASE, Wildfly 
> 14.0.1
>            Reporter: Steve Potter
>            Assignee: Neil Griffin
>            Priority: Major
>         Attachments: pluto-debug.txt, test-portlet-mvc.zip, test-portlet.zip
> When a serveResource method forwards to a servlet which then forwards to a 
> jsp, theĀ  HttpServletPortletRequestWrapper provides the path from the first 
> forward rather than the second forward and the jsp is not rendered.
> This is the process used by Spring Portlet MVC to locate JSP 'views' 
> resulting in the failure of all our portlets when trying to serve JSP's in 
> response to resource requests.
> The attached file contains a DEBUG log of the processing flow attempting to 
> serve '/WEB-INF/jsp/resource2.jsp' in response to a resource request.

This message was sent by Atlassian Jira

Reply via email to