On Thu, 2018-02-22 at 12:21 +0100, Francesco Pretto wrote:
> +    ePdfPageSize_Unknown = 0xff

while it adds to completeness, it's not good. The type is used for
input values only, not output, thus it's better to not have there the
'unknown' value. Not talking that it generates new compiler warning:
   src/doc/PdfPage.cpp: In static member function ‘static PoDoFo::PdfRect 
PoDoFo::PdfPage::CreateStandardPageSize(PoDoFo::EPdfPageSize, bool)’:
   src/doc/PdfPage.cpp:155:11: warning: enumeration value 
‘ePdfPageSize_Unknown’ not handled in switch [-Wswitch-enum]
     switch( ePageSize )

Thus I'm against this change.
        Thanks and bye,

Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
Podofo-users mailing list

Reply via email to