> 
> My problem is solved. I didn't realise, when building the 64-bit 
> version, that I still had to have some 32-bit libraries.

No.  In Linux 64-bit program can not use 32-bit libraries.  At
best 32-bit libraries are useless for 64-bit program, at worst
they can cause trouble when system finds incompatible library.

> I discovered 
> this after I installed the 32-bit version and then tried again to build 
> the 64-bit one. It succeeded this time.
> 
> It might be worth documenting for 64-bit Ubuntu systems that the 
> following packages have to be installed before installing either 32 or 
> 64 Poplog:
> 
> sudo apt instal|l multiarch-support |||libxm4:i386 libxext6:i386 
> libxt6:i386 libx11-6:i386

It would be good to know what really happended on your system.
One guess is that installing 32-bit stuff pulled in via dependencies
some architecure-independent stuff.  In particular you need 64-bit
developement packages like libxt6-devel (or whatever Ubuntu calls it).
On modern Linux distributions developement packages are _not_
installed by default.  Without developement packages you can run
already linked programs, but can not link a new one.

There may be some other problem, but installing 32-bit suff for
64-bit Poplog is a WRONG thing, at best it masks real problem.

Sorry if what I wrote sounds harsh, but unforunately wrong
information spreads out fast and it is important to rebuke it
quickly.

-- 
                              Waldek Hebisch

Reply via email to