A Divendres, 29 de maig de 2009, Shen Liang va escriure: > patch for pdftopng
The SplashBitmap::writePNGFile implementation has lots of commented code (either remove it if not needed or uncomment it if needed) and also doesn't implement nor gives errors case splashModeMono8: and some others. Also pdftopng.cc is 99.01% similar to pdftoppm.cc it would be a great idea if the code was either merged in and splitted into a separate file. Having duplicate code is a nightmare when speaking of maintainership. Albert > > ---------- Forwarded message ---------- > From: Shen Liang <[email protected]> > Date: Tue, May 26, 2009 at 12:47 PM > Subject: Re: [poppler] Fwd: Donate some codes for poppler > To: Albert Astals Cid <[email protected]> > > > I'm sorry I got a mistake on the attach. > > On Sat, May 23, 2009 at 5:57 PM, Albert Astals Cid <[email protected]> wrote: > > A Divendres, 22 de maig de 2009, Shen Liang va escriure: > >> I'd like to donate some codes for Poppler. I added pdftopng by > >> modifying pdftoppm. The codes were quit dirty now, and I will do more > >> later. > > > > Hi, thanks for contributing to poppler :-) > > > > Unfortunately the zip you attach is not correct. > > > > First for pdftopng you are attaching a shell scripts instead of the code. > > > > Second for already existing files like SplashBitmap.[cc|h] you should > > attach a diff file as generated by git diff if you use git or diff -u if > > you are working on released tarballs. > > > > Albert > > > > _______________________________________________ > > poppler mailing list > > [email protected] > > http://lists.freedesktop.org/mailman/listinfo/poppler > > -- > Help Si Chuan Students > 帮助四川灾区学生 > https://match.sichuanteachers.org > 四川教师志愿者组织 _______________________________________________ poppler mailing list [email protected] http://lists.freedesktop.org/mailman/listinfo/poppler
