I've thought some more about it. I think I would really prefer that we pivoted from debug- to debug_, in order not to change the rules for stem recognition in packagenames.
Granted, there is a small price to pay during the transition (mostly looking for both debug- and debug_ for a little while plus conflicting with debug_ in order to update debug packages). But that's a one shot, and once the transition is done, we can simplify wipe the extra code. Or heck, we don't even bother. After all, debug packages are only used for... debugging, not many people are using them, and they would know what to do (hopefully). So, yeah, much prefer debug_.
