On Thu, Aug 10, 2017 at 03:21:13PM -0400, Jeremie Courreges-Anglas wrote:
> 
> I've cooked a diff to allow building memtest86+ with clang.  Great.  The
> problem is that I just get a black screen on this x61 laptop (the only
> noticeable thing is that the cursor stays in the middle of the screen).
> 
> The only problem is, I get the same result with a build with base gcc.
> 
> Could people please apply the diff below, build and install memtest86+,
> and then test it?  Just type
> 
>   > boot memtest
> 
> at the boot(8) prompt.
> 
> Years ago I had tested this on an x240 machine, and I blamed the failure
> on my laptop being too recent.  But maybe that stuff is plain broken
> since years.
> 
> Both i386 and amd64 could be tested, btw.  Thanks in advance.
> 
> PS: earlier I had tried to update the port to the latest version but
> didn't get it to build.  Maybe this time...
> 
> 
> Index: Makefile
> ===================================================================
> RCS file: /d/cvs/ports/sysutils/memtest86+/Makefile,v
> retrieving revision 1.10
> diff -u -p -r1.10 Makefile
> --- Makefile  4 Feb 2014 10:14:52 -0000       1.10
> +++ Makefile  10 Aug 2017 07:37:10 -0000
> @@ -3,6 +3,9 @@
>  
>  ONLY_FOR_ARCHS=              amd64 i386
>  
> +# XXX base gcc
> +CC=                  /usr/bin/gcc
> +
>  COMMENT=             thorough, stand alone memory test
>  VERSION=             4.20
>  DISTNAME=            memtest86+-${VERSION}
Works fine here with your patch on my amd64 X230.

Any particular reasons we're still at 4.20 instead of 5.01?

Reply via email to