On 9/21/2016 8:42 AM, Alex Hall wrote:
> I just sent a test message to my work address. The log is below.
> Following that, I'll post postconf -n. Obviously, I've changed the
> server name to just 'server' and our domain to 'domain.com
> <http://domain.com>'. After I send this, I'm going to enable
> debug-level logging and see what that tells me, if anything. I'm
> hoping something will jump out from the below outputs, though.
> Sep 21 09:23:06 server postfix/pickup[3473]: 0869E60D29: uid=0
> from=<root>
> Sep 21 09:23:06 server24 postfix/cleanup[3501]: 0869E60D29:
> message-id=<20160921132306.0869e60...@server.domain.com
> <mailto:20160921132306.0869e60...@server.domain.com>>
> Sep 21 09:23:06 server postfix/qmgr[2705]: 0869E60D29:
> from=<r...@domain.com <mailto:r...@domain.com>>, size=320, nrcpt=1
> (queue active)
> Sep 21 09:23:06 server postfix/local[3503]: 0869E60D29:
> to=<ah...@domain.com <mailto:ah...@domain.com>>, relay=local,
> delay=0.02, delays=0.01/0/0/0, dsn=2.0.0, status=sent (delivered to
> command: procmail -a "$EXTENSION")
> Sep 21 09:23:06 server postfix/qmgr[2705]: 0869E60D29: removed

Your mail was delivered locally because you list your domain in

To deliver your domain remotely, list it in relay_domains.  List
valid recipients in relay_recipients_maps.


  -- Noel Jones

> postconf -n:
> alias_database = hash:/etc/aliases
> alias_maps = hash:/etc/aliases
> append_dot_mydomain = no
> biff = no
> config_directory = /etc/postfix
> inet_interfaces = all
> mailbox_command = procmail -a "$EXTENSION"
> mailbox_size_limit = 0
> mydestination = domain.com <http://domain.com>, localhost.domain.com
> <http://localhost.domain.com>, localhost
> mydomain = domain.com <http://domain.com>
> myhostname = server.domain.com <http://server.domain.com>
> mynetworks = <>, [::1]/128
> myorigin = /etc/mailname
> readme_directory = no
> recipient_delimiter = +
> relayhost = [smtp.mandrillapp.com <http://smtp.mandrillapp.com>]
> smtp_sasl_auth_enable = yes
> smtp_sasl_password_maps = hash:/etc/postfix/sasl_password
> smtp_sasl_security_options = noanonymous
> smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
> smtp_use_tls = yes
> smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
> smtpd_relay_restrictions = permit_mynetworks
> permit_sasl_authenticated defer_unauth_destination
> smtpd_tls_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
> smtpd_tls_key_file = /etc/ssl/private/ssl-cert-snakeoil.key
> smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
> smtpd_use_tls = yes
> On Tue, Sep 20, 2016 at 5:42 PM, rightkicktech.gmail.com
> <http://rightkicktech.gmail.com> <rightkickt...@gmail.com
> <mailto:rightkickt...@gmail.com>> wrote:
>     Hi Alex,
>     You should be able to see more details in /var/log/mail.log.
>     postfix is pretty verbose in the logs. Try sending a test mail
>     and observe the log file. Revert with the relevant entry to see
>     what happened.
>     On September 21, 2016 12:30:27 AM EEST, Alex Hall
>     <ah...@autodist.com <mailto:ah...@autodist.com>> wrote:
>         Hello list,
>         A very quick intro first. I work for a company that uses all
>         virtual servers, a change we recently adopted. I'm setting
>         up Request Tracker for internal use, which requires a Linux
>         system to run. Thus, I'm learning about Linux and all of
>         RT's required packages at the same time. I'm comfortable on
>         the command line, and know the basics of Bash, but I'm no
>         expert. I'm running Debian 8, Postfix, Fetchmail, and
>         Request Tracker, all with the latest updates as of today.
>         Our company uses Google Apps to manage mail for our domain,
>         so my address (ah...@domain.com <mailto:ah...@domain.com>)
>         is essentially a Gmail address. That'll be important in a
>         minute.
>         Now, to why I'm sending this email. To make sure RT was
>         going to work, I set it up on a Digital Ocean server, also
>         Debian, and was able to get things working pretty easily.
>         The bit that matters here is that I was able to get Postfix
>         working; it would send out emails as Request Tracker told it
>         to, and everyone received them with no problem. Since that
>         worked, my boss told me to move it to a virtual server on
>         our network, which I did. That was two weeks ago, and since
>         that move, not one email has been received by anyone in the
>         company from that server.
>         From all I can tell, Postfix is doing it right: it sends the
>         emails, and so long as the recipient is *not* @domain.com
>         <http://domain.com>, the message is delivered. If it *is*
>         @domain.com <http://domain.com>, the message silently
>         disappears. This holds true whether I use Gmail or Mandrill
>         as the relay for Postfix--non-company addresses work,
>         company ones do not. The Mandrill logs seem to indicate that
>         my messages lack a sender, which suggests that my envelope
>         may be malformed, thus causing Gmail to flip out when it
>         sees them.
>         What I hope people on this list can offer are suggestions
>         regarding what I can do to fix this. Why my Digital Ocean
>         server worked perfectly, and my internal, virtual server
>         doesn't is the biggest mystery. I don't know how to tell
>         Postfix to let me see the full details of outgoing messages
>         so I can examine them. Oh, speaking of outgoing messages, RT
>         isn't the only one whose messages run into this problem. The
>         following command encounters it, too, despite my extra headers:
>         echo "test" | mail -s "test" -a "from: Postfix
>         <validusern...@domain.com
>         <mailto:validusern...@domain.com>>" -a "reply-to: Postfix
>         <validusern...@domain.com
>         <mailto:validusern...@domain.com>>" ah...@domain.com
>         <mailto:ah...@domain.com>
>         My server seems to have the right name, too. The result of
>         'hostname' is 'myServerName', and 'hostname -f' is
>         'myservern...@domain.com <mailto:myservern...@domain.com>'.
>         I have no aliases set up, but neither did I on the Digital
>         Ocean server; this server is meant for RT, not to send out
>         its own emails, so I don't think I need aliases. (?)
>         Bottom line: on one server, everything was great. On my
>         company's virtual server, with the same configuration,
>         packages, and settings, mail sent out is silently discarded
>         by Gmail when delivered to anyone on the company's domain. I
>         must be missing required envelope details somewhere, but I
>         don't know where. I'm hoping someone can suggest where I can
>         look, and what I can try, to fix this. Please let me know
>         what additional information is required to troubleshoot this
>         problem. Thank you in advance.
>     -- 
>     Sent from my Android device with K-9 Mail. Please excuse my brevity.
> -- 
> Alex Hall
> Automatic Distributors, IT department
> ah...@autodist.com <mailto:ah...@autodist.com>

Reply via email to