My thanks to those who suggested the debug document. While that wasn't
it, the issue wasn't with postfix at all, it did get me looking at
Dovecot. Postfix does Sasl authentication using Dovecot. Dovecot gets
it's username and password from a MySQL database. The query Dovecot
was sending was wrong and it only showed up on outgoing connections,
incoming authentication worked fine.

Again my thanks.

On 2/11/18, Bill Cole <postfixlists-070...@billmail.scconsult.com> wrote:
> On 11 Feb 2018, at 18:12, David Mehler wrote:
>> Hello,
>> Does anyone have Android's aquamail app successfully connecting to a
>> Postfix server? If so, w hat settings did you use? I keep getting an
>> authentication denied error. I've tried for authentication choose
>> automatically, sasl plain, sasl login. For server security I've tried
>> ssl strict check, ssl accept any (both on port 465), and starttls
>> strict check and starttls accept any (port 587).
> This reads as if you haven't tried simply telling Postfix to not request
> client certs at all. Unless you are using X.509 certs for user
> authentication, it is best to leave smtpd_tls_CAfile and
> smtpd_tls_CApath at their defaults (empty) and smtpd_tls_ask_ccert at
> its default (no)
> And as always: if you want detailed and specific Postfix help here, you
> should follow the advice in the last section of the Postfix DEBUG_README
> file.

Reply via email to