--- In [email protected], "dleidinger" <[EMAIL PROTECTED]> wrote: > > Hi Alan, > > > got the new version 1.18 but doesn't work here. When i add the flag > > "allowoverwrite" the filename is proposed as "allowoverwrite" and the > > warning-popup of existing file still appears. > > May be a windows-version-problem. I use XP SP3.
> By the way, having the possibility to give a filename as a proposal > would also be a nice option. Ur, sorry. Reason your test failed was that I'd already implemented a trailing argument (filename), but I failed to document. see dialogplugin1.18provisional080718.zip in http://tech.groups.yahoo.com/group/power-pro/files/0_TEMP_/AlansPluginProvisional/ But now flag keywords are part of first arg (hmm, bestter call them options instead of flags...) -- changed the first <type> parameter of browse_for_file service to <type_and_flags>, and added numerous flag keywords. <type_and_flags> is now required, not optional. -- forgot to document trailing parameter to browse_for_file service call <defaultFileName>. -- added trailing parameter to browse_for_file service call <varNameROstate>. -- added code to return multiple file selections from browse_for_file service Try that.... Off line now til midweek next week.
