Dear Prosody Developers,

Our installation of Prosody-0.9.8 is not starting. We compiled it from source in the following environment. When we type prosodyctl start, it gives the error. What are we missing?


·Any dependencies?

·Or ordering of modules in events.lua?

Error

/usr/local/lua-5.3.0/bin/lua: /usr/local/lib/prosody-0.9.8/prosody/util/events.lua:16: attempt to call a nil value (global 'module')

stack traceback:

/usr/local/lib/prosody-0.9.8/prosody/util/events.lua:16: in main chunk

       [C]: in function 'require'

/usr/local/bin/prosodyctl:49: in main chunk

      [C]: in ?

Environment: CentOS 7, Lua 5.3 (compiled from source)

Dependencies installed: (installed from EPEL)

lua-socket 3.0.0

lua-sec 0.5.4

lua-expat 1.3.0

lua-filesystem 1.6.2

lua-dbi 0.5.11

Lua-devel 5.1.4
libevent-2.0.21   and its -devel.



--

Regards,

Susheel Jalali

Customer Operations Leader,

Coscend Communications Solutions

_Susheel.Jalali@CoscendCommunications.com_

Web site:www.CoscendCommunications.com <http://www.coscendcommunications.com/>

------------------------------------------------------------------

CONFIDENTIALITY NOTICE: See 'Confidentiality Notice Regarding E-mail Messages from Coscend Communications Solutions' posted at: http://www.CoscendCommunications.com/Terms_and_Conditions.html <http://www.coscendcommunications.com/Terms_and_Conditions.html>

--
You received this message because you are subscribed to the Google Groups 
"prosody-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to prosody-dev+unsubscr...@googlegroups.com.
To post to this group, send email to prosody-dev@googlegroups.com.
Visit this group at http://groups.google.com/group/prosody-dev.
For more options, visit https://groups.google.com/d/optout.

Reply via email to