The steps that I use for the Complex Hierarchy and Complex-->Simple
transformation are:

Create "top" level, and _all_ lower sheets as sheet symbols. Identify each
sheet symbol as "Channel n", with file name "Channel n.sch" etc...
Create one real "master" sheet for the multi-channel sheets (eg. "Channel
1.sch").
>From the "Documents" folder, use "Copy" then "Paste Shortcut" to create as
many shortcuts of this master channel as needed, and rename them "Channel
2.sch", Channel 3.sch" etc...
Press F5 in the Explorer panel to rebuild, and you should see the Shortcuts
(Ch. 2 etc...) fall into place in the hierarchy.
Work on master channel only (i.e. Channel 1, the only "real" sheet).
When satisfied, run Complex-->Simple. This will replace your shortcuts with
real sheets.

==> note that there seems to be a bug in the Explorer display such that the
Shortcut symbol (the little arrow) is not removed until you close the DDB
and re-open. Then you should see all the sheets Channel 1, Channel 2 etc...
as real sheets.

Re-annotate.

BOM should then find all sheets.

The crucial parts are that you need "shortcuts" of all sub-sheets (that are
supposed to be copies of the master channel), and you use Complex-->Simple
to convert these to real sheets.

Another tip is to keep a copy of the shortcuts (in a sub folder), so that if
you have to edit the master (and go through the whole Complex-->Simple
process), you just copy the shortcuts over the top of the other channel
files.

Hope that helps!


Damon Kelly
Hardware Engineer


> -----Original Message-----
> From: Bevan Weiss [mailto:[EMAIL PROTECTED]]
> Sent: Tuesday, 24 September 2002 11:59
> To: Protel EDA Forum
> Subject: [PEDA] BOM and complex heirachies
> 
> 
> Hi,
> another question.
> 
> When performing a BOM on a complex heirachy schematic layout, 
> I don't seem
> to get components called out right... It's always deficient.
> with two sheet symbols (with the same schematic), and a 
> holding schematic
> ie total.sch    ->    audio.sch
>                     ->    audio.sch
> 
> I only seem to get the parts for audio.sch reported once, not 
> the two times
> I woudl expect.  This is even after doing a complex to simple 
> (which doesn't
> seem to change anything that I notice).
> 
> Any help?
> 

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
* To post a message: mailto:[EMAIL PROTECTED]
*
* To leave this list visit:
* http://www.techservinc.com/protelusers/leave.html
*
* Contact the list manager:
* mailto:[EMAIL PROTECTED]
*
* Forum Guidelines Rules:
* http://www.techservinc.com/protelusers/forumrules.html
*
* Browse or Search previous postings:
* http://www.mail-archive.com/proteledaforum@techservinc.com
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Reply via email to