On Thu, Jun 25, 2009 at 6:59 PM, vikram <patilvik...@gmail.com> wrote:

> Hello guys,
>       I am actually attempting to compile protocol buffer source on
> AIX 5.3 and xlC 3.55 .
> It seems that I am able to compile it correctly but when it tried to
> use created protoc compiler it fails.
> So following it the snapshot of what happens when I do make. basically
> it can not replace ./$^ with appropriate prerequisites

Yeah, you need to use gmake.

> I created this simplest proto file to check whether it works fine. But
> when I tried tocompile it with create protoc binary ( .libs/lt-
> protoc ) it blocked in infinite loop.

Can you run in a debugger, ctrl+c during the loop, and give me the stack

> But with "option" uncommented it creates coredump
> ./src/.libs/lt-protoc src/google/protobuf/test.proto -I. --cpp_out=.
> Assertion failed: f == NULL || dynamic_cast<To>(f) != NULL, file  ./
> google/protobuf/stubs/common.h, line 282
> IOT/Abort trap (core dumped)

You are using v2.1.0, right?

Does your compiler support RTTI?

You received this message because you are subscribed to the Google Groups 
"Protocol Buffers" group.
To post to this group, send email to protobuf@googlegroups.com
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to