What steps will reproduce the problem?

        My aim is to use Google Proto buff on VxWorks for C++. I ran below
commands on cygwin in Windows7 machine.
        *) ./configure --target=powerpc-wrs-vxworks --enable-static=no --
disable-shared --with-protoc=protoc --enable-Multithreading
        *) make
        *) This generated 3 .a files in "protobuf-2.2.0\src\.libs". They are
libprotobuf.a, libprotobuf-lite.a and libprotoc.a

        Now I wanted to use these .a files (lib files) in my software to
encode using GPB. So I copied these library files and I tried to build
using scons in my package.

What is the expected output? What do you see instead?
        I expected the scons to build smoothly. But it came with below issues
and scons build failed.

        *) Undefined symbol:
           I understand that this symbol is defined in

What version of the product are you using? On what operating system?

        2.2.0, installed over cygwin in Windows 7 and configured with
   /configure --target=powerpc-wrs-vxworks --enable-static=no --
disable-shared --with-protoc=protoc --enable-Multithreading

You received this message because you are subscribed to the Google Groups 
"Protocol Buffers" group.
To post to this group, send email to protobuf@googlegroups.com.
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to