Status: New
Owner: liuj...@google.com
Labels: Type-Defect Priority-Medium

New issue 397 by jaysoona...@gmail.com: problem of using protobuf on hadoop
http://code.google.com/p/protobuf/issues/detail?id=397

What steps will reproduce the problem?
1.Compile my .proto file with java_out.
2.It's right when I run my program on local enviroment. My local environment is Windows7 32bit system, Eclipse IDE, jdk 1.6 and Hadoop plug-in of Eclipse. 3.It's wrong when I run my program on distribute enviroment. The distribute environment is CentOS5.4 64bit system, jdk 1.7 and hadoop.

What is the expected output? What do you see instead?

The result as fellow, it show that the field cann't be found.

FATAL org.apache.hadoop.mapred.Child: Error running child : java.lang.NoSuchFieldError: alwaysUseFieldBuilders
        at urlpackage.MainTable$MainTableData.access$1800(MainTable.java:696)
at urlpackage.MainTable$MainTableData$Builder.maybeForceBuilderInitialization(MainTable.java:897)
        at urlpackage.MainTable$MainTableData$Builder.<init>(MainTable.java:889)
        at urlpackage.MainTable$MainTableData$Builder.create(MainTable.java:902)
at urlpackage.MainTable$MainTableData$Builder.access$1600(MainTable.java:874)
        at urlpackage.MainTable$MainTableData.newBuilder(MainTable.java:861)


What version of the product are you using? On what operating system?
protobuf-2.4.1
CentOS

Please provide any additional information below.

Surprisingly, when I use protobuf-2.3.0 on distribute environment, my program can run exactly. Why?




--
You received this message because you are subscribed to the Google Groups "Protocol 
Buffers" group.
To post to this group, send email to protobuf@googlegroups.com.
To unsubscribe from this group, send email to 
protobuf+unsubscr...@googlegroups.com.
For more options, visit this group at 
http://groups.google.com/group/protobuf?hl=en.

Reply via email to