Status: New
Owner: liuj...@google.com
Labels: Type-Defect Priority-Medium

New issue 535 by dave.ros...@gmail.com: Rebuild doesn't complete
http://code.google.com/p/protobuf/issues/detail?id=535

What steps will reproduce the problem?
1. Build the solution
2. Then rebuild the solution
3.

What is the expected output? What do you see instead?
I expected the rebuild to complete like the initial build, however each projects rebuild cleans out either the Release directory or the Debug directory removing the previous projects build files except for some tag or flag that marks the individual project as 'completed'. The subsequent projects that depend upon the output of the previous ones then fail to build.

What version of the product are you using? On what operating system?
version 2.5.0 on windows 7 with visual studio 2012 pro

Please provide any additional information below.
It seems that when the subprojects all use the same Release and Debug output directories they delete each others files during a 'Rebuild'. Also parallel builds seem to have similar issues.

--
You received this message because this project is configured to send all issue notifications to this address.
You may adjust your notification preferences at:
https://code.google.com/hosting/settings

--
You received this message because you are subscribed to the Google Groups "Protocol 
Buffers" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to protobuf+unsubscr...@googlegroups.com.
To post to this group, send email to protobuf@googlegroups.com.
Visit this group at http://groups.google.com/group/protobuf.
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to