I also ran into this exact same SyntaxError issue with google-apputils
while trying to build with Python 3.

I also found the following issue with google-apputils-python:

    https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=760129

It looks like google-apputils-python declares a versioned dependency on
python-dateutil <2 for some reason, while in Debian we have (for Python
3, only) python-dateutil 2.0.  (And for Debian we have the requirement
that packages must build without downloading random content from the
Internet, e.g. through ez_setup and the like.)

'Feng Xiao' via Protocol Buffers wrote:
> +Aaron has reported the same issue. Seems there are some issues around
> google-apputils. Can you help file an issue here:
> https://github.com/google/protobuf/issues?
> 
> 
> On Mon, Sep 1, 2014 at 3:03 AM, EARob Agar <ea.rob.a...@gmail.com> wrote:
> 
> > How can I install protobuf 2.6 for use by python 3?  Both *pip3 install
> > protobuf* and manual installation with *python3 setup.py build* fail with
> > an InvalidSyntax exception in ez_setup.py.
> >
> > FWIW, here's the full stack trace
> >
> > rob@rob-pc:~/lib/protobuf/python$ python3 setup.py build
> > Traceback (most recent call last):
> >   File "setup.py", line 199, in <module>
> >     "Protocol Buffers are Google's data interchange format.",
> >   File "/usr/lib/python3.4/distutils/core.py", line 108, in setup
> >     _setup_distribution = dist = klass(attrs)
> >   File "/usr/local/lib/python3.4/dist-packages/setuptools/dist.py", line
> > 262, in __init__
> >     self.fetch_build_eggs(attrs['setup_requires'])
> >   File "/usr/local/lib/python3.4/dist-packages/setuptools/dist.py", line
> > 287, in fetch_build_eggs
> >     replace_conflicting=True,
> >   File "/usr/local/lib/python3.4/dist-packages/pkg_resources.py", line
> > 631, in resolve
> >     dist = best[req.key] = env.best_match(req, ws, installer)
> >   File "/usr/local/lib/python3.4/dist-packages/pkg_resources.py", line
> > 874, in best_match
> >     return self.obtain(req, installer)
> >   File "/usr/local/lib/python3.4/dist-packages/pkg_resources.py", line
> > 886, in obtain
> >     return installer(requirement)
> >   File "/usr/local/lib/python3.4/dist-packages/setuptools/dist.py", line
> > 338, in fetch_build_egg
> >     return cmd.easy_install(req)
> >   File
> > "/usr/local/lib/python3.4/dist-packages/setuptools/command/easy_install.py",
> > line 613, in easy_install
> >     return self.install_item(spec, dist.location, tmpdir, deps)
> >   File
> > "/usr/local/lib/python3.4/dist-packages/setuptools/command/easy_install.py",
> > line 643, in install_item
> >     dists = self.install_eggs(spec, download, tmpdir)
> >   File
> > "/usr/local/lib/python3.4/dist-packages/setuptools/command/easy_install.py",
> > line 833, in install_eggs
> >     return self.build_and_install(setup_script, setup_base)
> >   File
> > "/usr/local/lib/python3.4/dist-packages/setuptools/command/easy_install.py",
> > line 1055, in build_and_install
> >     self.run_setup(setup_script, setup_base, args)
> >   File
> > "/usr/local/lib/python3.4/dist-packages/setuptools/command/easy_install.py",
> > line 1040, in run_setup
> >     run_setup(setup_script, args)
> >   File "/usr/local/lib/python3.4/dist-packages/setuptools/sandbox.py",
> > line 68, in run_setup
> >     DirectorySandbox(setup_dir).run(runner)
> >   File "/usr/local/lib/python3.4/dist-packages/setuptools/sandbox.py",
> > line 114, in run
> >     return func()
> >   File "/usr/local/lib/python3.4/dist-packages/setuptools/sandbox.py",
> > line 67, in runner
> >     _execfile(setup_script, ns)
> >   File "/usr/local/lib/python3.4/dist-packages/setuptools/sandbox.py",
> > line 43, in _execfile
> >     exec(code, globals, locals)
> >   File "/tmp/easy_install-thdmg8q1/google-apputils-0.4.0/setup.py", line
> > 18, in <module>
> >     sys.stderr.write(
> >   File "/tmp/easy_install-thdmg8q1/google-apputils-0.4.0/ez_setup.py",
> > line 79
> >     except pkg_resources.VersionConflict, e:
> >                                         ^
> > SyntaxError: invalid syntax

-- 
Robert Edmonds

-- 
You received this message because you are subscribed to the Google Groups 
"Protocol Buffers" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to protobuf+unsubscr...@googlegroups.com.
To post to this group, send email to protobuf@googlegroups.com.
Visit this group at http://groups.google.com/group/protobuf.
For more options, visit https://groups.google.com/d/optout.

Reply via email to