I'm pretty sure this is actually a problem in google apputils, which is
where the versioned dependency on python-dateutil < 2 comes from.
I filed a Debian bug on this about a week ago.
'Feng Xiao' via Protocol Buffers wrote:
> Could you help file an issue here: https://github.com/google/protobuf/issues
> On Tue, Sep 9, 2014 at 9:20 AM, Rich <rich.bur...@gmail.com> wrote:
> > PIP install fails since 2.6.0 (released 8/25/14)
> > pip install protobuf
> > Traceback (most recent call last):
> > File "<string>", line 17, in <module>
> > File
> > "/Users/burdon/projects/src/alienlaboratories/core/tools/python/build/protobuf/setup.py"
> > , line 199, in <module>
> > ...
> > pkg_resources.VersionConflict: (python-dateutil 2.2 (/Users/burdon/
> > projects/src/alienlaboratories/core/tools/python/lib/python2.7/site-
> > packages), Requirement.parse('python-dateutil>=1.4,<2'))
> > But the default public index for python-dateutil is 2.2 (
> > https://pypi.python.org/pypi/python-dateutil)
> > The workaround is to downgrade to 1.5 (pip install -U python-dateutil==1.5)
> > But this wasn't necessary for 2.5.0
> I don't think we have changed this in 2.6.0. Maybe it's due to a change of
> the dateutil package?
You received this message because you are subscribed to the Google Groups
"Protocol Buffers" group.
To unsubscribe from this group and stop receiving emails from it, send an email
To post to this group, send email to email@example.com.
Visit this group at http://groups.google.com/group/protobuf.
For more options, visit https://groups.google.com/d/optout.