Hello,

I am not a professional programmer, use Windows 7 and Visual Studio 2013 to 
program and I use my PC for everything, not just programming.
So it has all kinds of stuff installed. Not sure if this matters and if 
this is even the right place to ask (if not, please tell me where to go), 
but anyway, here is my question/problem:

Yesterday I wanted to compile protobuf-2.6.0 into static libraries to use 
in my project so I read and followed the instructions in 
\protobuf-2.6.0\vsprojects\readme.txt
I opened the protobuf.sln in Visual Studio 2013, it said it needed to run 
the auto-convert so I clicked yes.
After that I tried to build the solution like instructed in the readme, but 
it failed because of some simultaneous accesses to some file, looked up 
what I need to do and added the /FS compiler option to every project.
Then I ran "Rebuild Solution" and it worked.
Now for the interesting part: "From a command shell, run tests.exe and 
lite-test.exe and check that all tests pass."
So I went into the \Debug folder, shift-rightclick "Open Command prompt 
here", entered tests.exe and pressed enter.
Everything went well except for two errors that I don't remeber and think 
are not important because I'm never going to use the features the errors 
were about anyways.
The problem about the whole thing is, after I was done compiling and got 
back to my main project, I got a lot of errors regarding missing header 
files. "boost.h" not found, "box2d.h" not found etc.
So I checked the folders and..... a lot of files were gone, but not all of 
them. The *.lib files of boost for instance were still there, but header 
files were deleted.
Was it a virus? Nope, virus check negative. Malware? Malware check 
negative. No alerts or anything, except of course the prompt to allow 
tests.exe to do it's thing.
Went into Comodo Internet Securitys Logfiles and found out that tests.exe 
"modified" (deleted) a bunch of apparently completely random files! 
Whaaaaat? Why? How? I don't get it...
Luckily windows was able to (almost) restore some of the folders back to 
their previous state, BUT I don't even know how many or which ones are 
affected. The only reference that I have is Comodos Logfile, which doesn't 
seem to list all 
files that got deleted. For instance it shows "C:\Program Files (x86)\Guild 
Wars 2\Gw2.exe" was modified by tests.exe, but all other files in that 
folder were gone EXCEPT Gw2.exe.
I have restored a lot of files that were logged, but am not sure if I 
missed anything and I don't know if the restore option will be available 
until the day I find out that more files were deleted.
I wanna know WHY this happened and if I can find out what else got deleted.
Sadly I am not experienced enough to decipher the protobuffer source files 
and find out where the code is that deleted everything and how it decided 
which files to delete.
Maybe I'm completely wrong about it being tests.exe but I cannot imagine 
anything else and the files were gone right after I ran it so i guess it 
has something to do with protobuf.

Here is part of the Comodo Logfile as an image since I don't know any site 
where I could upload an html file: http://oi58.tinypic.com/2469h8i.jpg

This is the second time I'm writing this because for some reason the first 
time I submitted my post nothing happened and I lost my original text and 
had to rewrite everything.
I'm not familiar with google groups so if this is normal behaviour and it 
takes a while for posts to appear I'm sorry for double posting.

-- 
You received this message because you are subscribed to the Google Groups 
"Protocol Buffers" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to protobuf+unsubscr...@googlegroups.com.
To post to this group, send email to protobuf@googlegroups.com.
Visit this group at http://groups.google.com/group/protobuf.
For more options, visit https://groups.google.com/d/optout.

Reply via email to