On Dec 13, 2012, at 6:22 PM, Rob Godfrey <rob.j.godf...@gmail.com> wrote:

> A couple of comments...
> 
> On 13 December 2012 23:37, Justin <jr...@redhat.com> wrote:
> 
>> API usability is important and deserves attention.
>> 
>> 
> <snip>
> 
> 
>> 
>>  pn_link_drain
>> 
>>    Existing C name:    pn_link_drain
>>    Proposed C name:    pn_link_rescind_credit
>>    Existing Java name: Receiver.drain
>>    Proposed Java name: Receiver.rescindCredit
>> 
>>    Consider pn_link_decrease_credit, pn_link_rescind_credit
>> 
>> 
> Drain *doesn't* rescind credit, or decrease credit, so I'd be -1 on these
> names. Drain is an indication that the sender should use all available
> credit, but if insufficient deliveries are available at the sender to use
> up all the credit, only then should it act as if all credit had been
> consumed.  At no point is the receiver rescinding credit.
> 
> <snip>
> 
> 
>>  pn_delivery_update
>> 
>>    Existing C name:    pn_delivery_update
>>    Proposed C name:    pn_delivery_acknowledge
>>    Existing Java name: Delivery.disposition
>>    Proposed Java name: Delivery.acknowledge
>> 
>>    Do calls to delivery.update correspond one-to-one to
>>    delivery.updated?  The naming implies a symmetry that I'm not sure
>>    is there.
>> 
>> 
> I'm -1 on acknowledged. Acknowledgement is one type of update, but not the
> only one. I'm fine with changing the Java to update() to match the C.
> 
> On things such as bitmaps vs. enums, I think that's just a language
> convention thing... I don't see a huge need to make such things identical.
> Naming is something that should be aligned between APIs however.
> 

That was the point of the thread, not nit picking certain things. 


> -- Rob
> 
> 
>> 
>> On Thu, 13 Dec 2012, Justin Ross (JIRA) wrote:
>> 
>> 
>>>   [ https://issues.apache.org/**jira/browse/PROTON-26?page=**
>>> com.atlassian.jira.plugin.**system.issuetabpanels:comment-**
>>> tabpanel&focusedCommentId=**13531571#comment-13531571<https://issues.apache.org/jira/browse/PROTON-26?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13531571#comment-13531571>]
>>> 
>>> Justin Ross commented on PROTON-26:
>>> ------------------------------**-----
>>> 
>>> That's really not the case.  Rejecting it is fine, but it's mostly gone
>>> undiscussed.  That's partly my fault.  A post to the mailing list with
>>> highlights suitable for inline comments is incoming.
>>> 
>>> Engine api naming proposal
>>>> --------------------------
>>>> 
>>>>                Key: PROTON-26
>>>>                URL: 
>>>> https://issues.apache.org/**jira/browse/PROTON-26<https://issues.apache.org/jira/browse/PROTON-26>
>>>>            Project: Qpid Proton
>>>>         Issue Type: Improvement
>>>>         Components: proton-c, proton-j
>>>>           Reporter: Justin Ross
>>>>           Assignee: Rafael H. Schloming
>>>>             Labels: api
>>>>            Fix For: 0.2
>>>> 
>>>>        Attachments: engine-naming-01.patch,
>>>> proton-engine-naming-proposal-**2.pdf, proton-engine-naming-proposal-**
>>>> 3.pdf
>>>> 
>>>> 
>>>> See https://docs.google.com/**spreadsheet/ccc?key=**
>>>> 0ArGmVtK1EBOMdEw0bkp4OE5UOWpRR**kx3RzVoTjliX0E#gid=0<https://docs.google.com/spreadsheet/ccc?key=0ArGmVtK1EBOMdEw0bkp4OE5UOWpRRkx3RzVoTjliX0E#gid=0>
>>>> 
>>> 
>>> --
>>> This message is automatically generated by JIRA.
>>> If you think it was sent incorrectly, please contact your JIRA
>>> administrators
>>> For more information on JIRA, see: http://www.atlassian.com/**
>>> software/jira <http://www.atlassian.com/software/jira>
>>> 
>>> 

Reply via email to