[ 
https://issues.apache.org/jira/browse/PROTON-221?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13575105#comment-13575105
 ] 

Cliff Jansen commented on PROTON-221:
-------------------------------------

I put in a temporary fix (r1444336) since the flags were causing a regression 
for those affected.  I will put the patch up for a normal review and adjust it 
as required.
                
> optionally set warning flags only if gcc version supports them
> --------------------------------------------------------------
>
>                 Key: PROTON-221
>                 URL: https://issues.apache.org/jira/browse/PROTON-221
>             Project: Qpid Proton
>          Issue Type: Bug
>          Components: proton-c
>    Affects Versions: 0.4
>         Environment: Building with gcc
>            Reporter: Cliff Jansen
>            Assignee: Cliff Jansen
>
> Older versions of gcc do not support the C++ compatibility flags.  Instead of 
> failing the build, they should print a warning that won't scare proton users.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Reply via email to