Hi Keith,

Ah, so sorry - I'll take a look.

My first instinct is to simply disable the valgrind tests for older versions, 
but let me check if I can fix the suppression in some backward compatible way.

/me valgrind noob.


----- Original Message -----
> From: "Keith W" <keith.w...@gmail.com>
> To: proton@qpid.apache.org
> Sent: Thursday, April 4, 2013 7:26:29 AM
> Subject: Valgrind based soak tests fail against earlier versions of valgrind 
> (3.2.1)
> 
> Hello
> 
> We are seeing a the valgrind based soak tests fail on boxes with
> earlier versions of valgrind (3.2.1).
> 
>  proton_tests.soak.MessengerTests.test_star_topology_valgrind
> ...............................................................................location
> should start with fun: or obj:
> ==1403== FATAL: in suppressions file
> '/home/keith/src/live/qpid-proton/tests/python/proton_tests/valgrind.supp':
> location should start with 'fun:' or 'obj:'
> ==1403== exiting now.
> 
> Is it possible to avoid the dependency on the newer version, or get
> config.sh to check the version of valgrind if it requires a specific
> version?
> 
> Thanks in advance, Keith
> 

-- 
-K

Reply via email to