[ 
https://issues.apache.org/jira/browse/PROTON-853?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14507617#comment-14507617
 ] 

ASF GitHub Bot commented on PROTON-853:
---------------------------------------

Github user asfgit closed the pull request at:

    https://github.com/apache/qpid-proton/pull/21


> [proton-j] the transport emitted a new link attach for a link in the process 
> of being detached
> ----------------------------------------------------------------------------------------------
>
>                 Key: PROTON-853
>                 URL: https://issues.apache.org/jira/browse/PROTON-853
>             Project: Qpid Proton
>          Issue Type: Bug
>          Components: proton-j
>    Affects Versions: 0.9
>            Reporter: Robbie Gemmell
>
> When upgrading to use 0.9 for the JMS client, we see some NPEs on the client 
> as it tries processing the events being emitted by the connection. This was 
> due to multiple link attach and detach frames arriving in the for the same 
> consumer link.
> What appears to be happening is that while closing the consumer, after the 
> client emits its detach frame proton then emits a new attach frame for the 
> link, before the server responds to the original detach, even though the 
> client made no attempt to recreate the consumer. It looks like the clients 
> handling of a flow frame which arrived after it emitted the original detach 
> meant that the link was modified, and the transport reacted by sending out a 
> new attach. This appears to be due to a change made in 0.9 for PROTON-154.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to