Hi all,

I have been trying to establish an SSL connection with proton-c on an apache
apollo server but have not been having any luck yet. I have tried setting up
certificates and key/trust stores with keytool, and linking to them with
pn_messenger_set_private_key and pn_messenger_set_certificate. I have also
tried correctly setting up the server. None of this is working at the
moment, any thoughts/tutorials anyone can direct me to?

This is what I am getting with PN_TRACE_FRM=1:
[0x1d2de30]:  -> AMQP
[0x1d2de30]:0 -> @open(16)
[container-id="16bddb71-593c-4493-b773-554875740222", hostname="127.0.0.1"]
[0x1d2de30]:0 -> @begin(17) [next-outgoing-id=0, incoming-window=2147483647,
outgoing-window=0]
[0x1d2de30]:0 -> @attach(18) [name="", handle=0, role=true,
snd-settle-mode=2, rcv-settle-mode=0, source=@source(40) [durable=0,
timeout=0, dynamic=false], target=@target(41) [durable=0, timeout=0,
dynamic=false], initial-delivery-count=0]
[0x1d2de30]:0 -> @flow(19) [incoming-window=2147483647, next-outgoing-id=0,
outgoing-window=0, handle=0, delivery-count=0, link-credit=1024,
drain=false]
[0x1d2de30]:0 -> @close(24) [error=@error(29)
[condition=:"amqp:connection:framing-error", description="AMQP header
mismatch: Unknown protocol ['\x15\x03\x01\x00\x02\x02P']"]]
[0x1d2de30]:  <- EOS




--
View this message in context: 
http://qpid.2158936.n2.nabble.com/Proton-c-SSL-Connection-tp7627249.html
Sent from the Apache Qpid Proton mailing list archive at Nabble.com.

Reply via email to