While browsing through the prototype source I saw:

1686   var Toggle = new Object();
1687   Toggle.display = Element.toggle;

What is the point of this? I for one already have my own class called
Toggle and I wouldn't be surprised if many other people do as well,
but we are unknowingly overwriting a Prototype "class" that is
undocumented and unnecessary. This isn't a huge deal until someone
uses this in some useful library, and then it is broken. IMO there is
nothing wrong with Element.toggle, so why steal another popular word
from the global namespace?

I would like to see this removed unless someone has a reason for this
being there. If necessary, I'll even submit the patch but I think it
should be removed before anyone uses it.  Let's please leave aliases
up to Prototype users and functionality up to Prototype Core.


You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to prototype-core@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 

Reply via email to