How 'bout Viewport.width, Viewport.offset, ...


On Jun 6, 2007, at 9:27 PM, Andrew Dupont wrote:

> We'd almost have to call them "viewportHeight" and
> "viewportWidth" (perhaps prepended with "get"), since we already have
> "viewportOffset." But I don't know where we'd put them -- they don't
> work as Element methods.
> I'd suggest "window" if it weren't the global namespace. Thoughts?
> Cheers,
> Andrew
> On Jun 6, 5:42 pm, Tobie Langel <[EMAIL PROTECTED]> wrote:
>> Hi Freddy,
>> There's a ticket in tract for that already.
>> the main thing that has been delaying it's implementation is finding
>> the right names for these mrthods, so any suggestion is welcomed.
>> Best,
>> Tobie
>> On Jun 6, 6:14 pm, Freddy <[EMAIL PROTECTED]> wrote:
>>> Hi Guys,
>>> as far as i know there is no possibility to calculate the size of
>>> browserwindow with prototype yet. But this could be very useful to
>>> place e.g. a div-popup in the middle of the window.
>>> I always use my own functions. If you also see a common need I would
>>> create a sample patch to include it in prototype. What do you think,
>>> is this useful or to specialized?
> >

You received this message because you are subscribed to the Google Groups 
"Prototype: Core" group.
To post to this group, send email to
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at

Reply via email to